AIX Articles RSS Feed
AIX 6/7 Script to create a file with commands to remove missing and failed paths
Viewed 3083 times since Tue, Jun 14, 2022
To create a file with commands to remove the missing paths 1 2 3 4 5 6 7 8 9 #!/bin/sh # rmpaths >xrmpaths echo "#!/bin/sh" >>xrmpaths disks=$(lspv | awk '{print $1}') for loop in $disks do lspath -l $loop -H -F "name:pare... Read More
AIX, user gets “pwd: The file access permissions do not allow the specified action.”
Viewed 10667 times since Tue, Mar 16, 2021
AIX, user gets “pwd: The file access permissions do not allow the specified action.” Just a short demonstration that file permissions matter on directories used as mount points under AIX6.1. Let’s say we have properly running system, the oracl... Read More
IBM AIX MPIO: Best practices and considerations
Viewed 10986 times since Wed, May 30, 2018
IBM AIX MPIO: Best practices and considerations Shannon Moore and Gary DomrowPublished on January 20, 2014 FacebookTwitterLinked InGoogle+E-mail this page 15 IBM Power Systems™ servers are designed to offer very high stand-alone av... Read More
R2dump debug tool
Viewed 1958 times since Tue, Sep 8, 2020
R2dump debug tool Troubleshooting Problem Customers may face a situation where a server is rebooted with no dump and nothing to explain the reason for the reboot in the error report or in the console log. Most commonly this is seen with... Read More
How to disable SSH cipher/ MAC algorithms for Linux and Unix
Viewed 44736 times since Fri, Aug 21, 2020
How to disable SSH cipher/ MAC algorithms for Linux and Unix HowtTos / November 04, 2019 / By: ayildirim Contents Step 1: Check existing configuration Step 2: Edit SSHD Configuration Step 3: Check the new configuration Some of the security con... Read More
Secure Secure Shell
Viewed 10349 times since Fri, Aug 21, 2020
Secure Secure Shell 2015-01-04 crypto, nsa, and ssh You may have heard that the NSA can decrypt SSH at least some of the time. If you have not, then read the latest batch of Snowden documents now. All of it. This post will still be here when you f... Read More
AIX FC Performance improvements for IBM AIX FC and FCoE device driver stacks
Viewed 5521 times since Fri, Jan 31, 2020
Performance improvements for IBM AIX FC and FCoE device driver stacks Multiple I/O queue support Yadagiri Rajaboina, Kiran Anumalasetty, Vinod Kumar Boddukuri, and Prashantha Subbarao Published on January 06, 2017 FacebookTwitterLinked InE-mai... Read More
IBM V7000f Performance Test with Vdbench Tool on IBM AIX
Viewed 15810 times since Thu, Jan 23, 2020
Firsty, you should download vdbench to oracle web site. You can see the name vdbench50406.zip like this. And you have to install java 8,because vdbench use Java8.Its required. Put java path to your root profile. vi .profile export PATH=/usr/java8... Read More
AIX disk queue depth tuning for performance
Viewed 14989 times since Thu, Jan 16, 2020
Purpose The purpose of this document is to describe how IOs are queued with SDD, SDDPCM, the disk device driver and the adapter device driver, and to explain how these can be tuned to increase performance. This information is also useful for non-SDD ... Read More
AIX Resolving "missing" or "removed" disks in AIX LVM
Viewed 4285 times since Tue, Aug 6, 2019
Technote (troubleshooting) Problem(Abstract) How do I get back a disk that is marked "missing" or "removed"? What does this mean? Symptom AIX LVM will mark a disk as "missing" when it cannot successfully determine if the disk belongs to the volume ... Read More
AIX Different Commands For Paging Space Administration swap file create
Viewed 7255 times since Thu, Aug 1, 2019
Posts Tagged ‘mkps’ Different Commands For Paging Space Administration leave a comment » This post will talk about various commands involved to carry out paging space administration. The first and foremost command always used is to chec... Read More
AIX TCP connection status
Viewed 16403 times since Mon, Jul 29, 2019
A TCP connection progresses through a series of states during its lifetime. The following diagram illustrates the possible states for a TCP connection and how the states transition based on various events from either the network or from the local T... Read More
AIX routing - How Do I Compare ODM with the Current Routing Table?
Viewed 2498 times since Mon, Jul 29, 2019
I'm new to AIX, but not to UNIX in general. My Solaris and IRIX get rustier with each passing day. I've been using RHEL for the last several years, though. My task it to write a shell script that compares the current routing table, from ne... Read More
How to install filesets/software in aix?
Viewed 5641 times since Mon, Jul 8, 2019
How to install filesets/software in aix? How to install filesets/software in aix?     To install the fileset from the cd: First create the directory (mount point)   #mkdir cdmnt Mount the cdrom    #mount –v cdrfs –o ro /dev/cd0 /cdmnt Then go to /cdm... Read More
7 Tips – Tuning Command Line History in Bash
Viewed 5006 times since Fri, Jul 5, 2019
7 Tips – Tuning Command Line History in Bash Posted on Tuesday December 27th, 2016by admin   7 Tips that can help you to improve you Bash history file. You will learn how to add date and time to bash history file, increase history size, ignore spe... Read More
ILMT Procedure - ILMT / TAD4D / SUA / BFI
Viewed 10000 times since Fri, Jul 5, 2019
ILMT / TAD4D / SUA / BFI IBM License Metric Tool (ILMT or LMT), Tivoli Asset Discovery for Distributed (TAD4D or TADd) and Software Use Analysis (SUA) for IBM Endpoint Manager (IEM) - this blog is about these tools. Tools that in general ... Read More
AIX Password expiry /etc/passwd
Viewed 18337 times since Wed, Jul 3, 2019
Password expiry Reviewing password attributes by David Tansley | Published August 31, 2010 Systems Introduction Password policy is the mechanism of ensuring and enforcing that an account is protected by a password authentication process. Syste... Read More
AIX Oracle tuning
Viewed 209525 times since Tue, Jul 2, 2019
AIX Oracle tuning Posted on June 15, 2010, updated on October 9, 2014 by Yannick Jaquier AIX, Oracle Tuning   Table of contents Preamble Environment variables Maximum number of processes VMM tuning VMM background maxclient% maxperm% minperm... Read More
How to set Kernel Parameters in AIX ?
Viewed 14490 times since Tue, Jul 2, 2019
Unlike many other UNIX operating systems, AIX does not provide the ability to directly configure most kernel parameters. Instead, the AIX kernel dynamically allocates and reallocates resources as they are needed (up to a predefined limit). To see all... Read More
How to Use the Linux lsof Command
Viewed 11364 times since Sun, Jun 30, 2019
If everything in Linux is a file, there has to be more to it than just files on your hard drive. This tutorial will show you how to use lsof to see all the other devices and processes that are being handled as files.   On Linux, Everything Is a Fi... Read More
Technology level update on AIX using smit_update and alt_disk_install method
Viewed 5561 times since Sun, Jun 30, 2019
echnology level update on AIX using smit_update and alt_disk_install method   AIX Technology level update Let first Understand AIX oslevel command output before TL update.   #oslevel -r 7100-04 7100 is AIX OS version. 04   is Technolgy level   # osle... Read More
AIX HOW TO CLONE A ROOTVG USING ALTERNATE DISK INSTALLATION ALTER_DISK_COPY
Viewed 16299 times since Sun, Jun 30, 2019
Sometimes we need to upgrade the AIX Technology Level (TL), but it cans became dangerous because imagine if we perform an upgrade and after that the system simply doesn’t start again, or maybe an application start getting locking. What I meant ... Read More
AIX Cloning a rootvg using alternate disk installation
Viewed 11341 times since Sun, Jun 30, 2019
Using this scenario, you can clone AIX® running on rootvg to an alternate disk on the same system, install a user-defined software bundle, and run a user-defined script to customize the AIX image on the alternate disk. The information in this how-to... Read More
AIX alt_disk_copy
Viewed 9675 times since Sun, Jun 30, 2019
Required filesets:    bos.alt_disk_install.boot_images    bos.alt_disk_install.rte    bos.msg.en_US.alt_disk_install.rtealt_disk_copy -d <hdisk to clone rootvg>             this will clone the rootvg to the specified diskalt_disk_copy -e /etc/e... Read More
How to upgrade TL and SP in AIX using alternate disk(alt_disk_copy)
Viewed 11026 times since Sun, Jun 30, 2019
Many method available to upgrade/patch AIX technology level(TL) and service pack(SP) to latest level.This is perfect method to update the AIX server using alternate disk, there is no impact to original rootvg whatever the upgrade you are performing t... Read More
Part 1, Memory overview and tuning memory parameters AIX7
Viewed 4038 times since Wed, Jun 19, 2019
Part one of a three-part series by Ken Milberg, Martin Brown | Published November 2, 2010 Systems Introduction As a systems administrator, you should already be familiar with the basics of memory, such as the differences between physical and v... Read More
Part 2, Monitoring memory usage (ps, sar, svmon, vmstat) and analyzing the results AIX7
Viewed 12423 times since Wed, Jun 19, 2019
Part two of a three-part series by Ken Milberg, Martin Brown | Published November 9, 2010 Systems Introduction The most important part of tuning your memory subsystem does not involve actual tuning. Before tuning your system, you must have a s... Read More
Part 3, Tuning swap space settings AIX7
Viewed 8891 times since Wed, Jun 19, 2019
Part three of a three-part series by Martin Brown, Ken Milberg | Published November 16, 2010 Systems About this series This three-part series focuses on the various aspects of memory management and tuning on IBM System p™ servers running AIX® ... Read More
How to start daemons at the system startup in AIX servers
Viewed 2311 times since Tue, Jun 18, 2019
AIX 5.3 1. Create a rc.local file in /etc/ 2. Apply proper permissions a. chown root:sys /etc/rc.local b. chmod 744 /etc/rc.local 3. Add an entry in /etc/inittab so whenever the server is rebooted the script will be started. a. mkitab -i rcnfs... Read More
n a perfect world....rootvg would always reside on hdisk0
Viewed 2162 times since Thu, Jun 6, 2019
In a perfect world, 99.9% of AIX administrators would prefer their systems to look like this:   # lspv | grep rootvg hdisk0         00c342c68dfcbdfb                    rootvg         active   However, in reality, 99.9% of AIX administrators live with... Read More
How to Maintain a Virtual I/O Server With FBO Part II
Viewed 10489 times since Wed, Jun 5, 2019
How to Maintain a Virtual I/O Server With FBO   October 2013 | by Jaqui Lynch   Print 0   Resource Editor’s Note: This is the second of a two-part series on Virtual I/O Server (VIOS) care and feeding. Part one discussed how to perf... Read More
How to Backup and Upgrade a Virtual I/O Server Part I
Viewed 4329 times since Wed, Jun 5, 2019
How to Backup and Upgrade a Virtual I/O Server   September 2013 | by Jaqui Lynch   Print 7   Available Downloads: Code Sample 1   Editor’s note: This is the first of a two-part series on Virtual I/O Server (VIOS) care and feeding.... Read More
HOWTO: Implement SEA Failover with Dual VIOS
Viewed 7391 times since Tue, Jun 4, 2019
In 2004 IBM released POWER5 with a very "Power"ful feature built-in - Virtual Ethernet. An additional feature known as Shared Ethernet Adapter (SEA) enables client partitions to communicate with via IP protocols without a requirement for a physical e... Read More
vfcpmap on VIO Server
Viewed 9331 times since Tue, Jun 4, 2019
vfcpmap on VIO Server   vfcmap command maps and unmaps the virtual fibre channel adapter to the physical fibre channel port.To Map the virtual fibre channel ,vfchost1 to the physical fibre channel port, fcs0 # vfcmap -vadapter vfchost0 -fcp fcs0To u... Read More
Installation of the Virtual I/O Server directly from the HMC
Viewed 19994 times since Tue, Jun 4, 2019
Installation of the Virtual I/O Server directly from the HMC    HMC firmware version 7.7.7 allows installation of the Virtual I/O Server directly from the HMC.   Steps: 1.Download VIOS installation .iso images from IBM website. 2.Copy installati... Read More
The new VIOS performance advisor tool part util
Viewed 3094 times since Tue, Jun 4, 2019
I updated my lab VIOS to the latest fix pack (V2.2.2.1) this week and thought I’d try the new VIOS part command. This new command is an improved version of the existing vios_advisor tool. The major difference between the two is the fact that th... Read More
Using expect to automate mundane tasks
Viewed 1784 times since Mon, Jun 3, 2019
I have a Power5 system I use for testing, no HMC and I cannot always depend on being at a location where I can use the web-based ASMI interface. Plus, I have to wait for the web-interface to load. I prefer to use the serial line connection from tty1 ... Read More
AIX Creating EtherChannel Devices from Command Line
Viewed 3286 times since Mon, Jun 3, 2019
I needed to create some EtherChannel devices on several AIX LPARs, and did not want to go through the smit panels every time. I was testing network performance and wanted to add these to a script, so I could test standalone adapter configurations vs ... Read More
Altering LVM Configuration When a Disk is Not in ODM Anymore
Viewed 2888 times since Mon, Jun 3, 2019
If you remove a disk from the system using rmdev -dl hdiskX without having previously reduced the volume group to remove the disk from LVM, and thus have not updated properly the on-disk format information (called VGDA), you get a discrepancy betwe... Read More
AIX 7.2 running on my Macbook?
Viewed 12199 times since Mon, Jun 3, 2019
After reading this https://worthdoingbadly.com/aixqemu and this https://lists.gnu.org/archive/html/qemu-ppc/2018-05/msg00387.html, I was inspired and very curious. Could I get AIX 7.2 running on QEMU on my MacBook Pro (running Mac OS X 10.13.6)?   We... Read More
AIX lsdevinfo
Viewed 10137 times since Mon, Jun 3, 2019
The lsdevinfo utility appears to an undocumented command. However it looks like it could come in handy occasionally. Here are some examples of using it on AIX 7.1:   # oslevel -s 7100-00-01-1037   # lslpp -w /usr/sbin/lsdevinfo   File                ... Read More
Using the AIX splitvg command
Viewed 4096 times since Mon, Jun 3, 2019
Using the AIX splitvg command. cggibbo |Mar 31 2010| Comments (5) | Visits (30446) 1 Just the other day, I needed to use the AIX splitvg command in order to copy some data from one system to another. I thought I’d share the experience here. The... Read More
Using splitvg in AIX to make a copy of a volume group
Viewed 8554 times since Mon, Jun 3, 2019
Technote (FAQ) Question How do I use splitvg to make a copy of a volume group I can back up? Answer Initial Volume Group Setup Start with a mirrored volume group: # lsvg -l zzvg zzvg: LV NAME            TYPE       LPs     PPs     PVs  LV STATE     ... Read More
AIX QHA
Viewed 10934 times since Mon, Jun 3, 2019
The standard tool for cluster monitoring is clstat, which comes along with PowerHA SystemMirror/HACMP. Clstat is rather slow with its updates, and sometimes the required clinfo deamon needs restarting in order to get it operational, so this is, well... Read More
AIX HA / HACMP, System Admin↑ Mountguard
Viewed 6404 times since Mon, Jun 3, 2019
Topics: PowerHA / HACMP, Storage Adding a new volume group to an active PowerHA resource group   This article describes how to add a new volume group to an existing resource group of an active PowerHA cluster. The first step is to add the stora... Read More
Topics: PowerHA / HACMP, Storage Adding a new volume group to an active PowerHA resource group
Viewed 2470 times since Mon, Jun 3, 2019
This article describes how to add a new volume group to an existing resource group of an active PowerHA cluster. The first step is to add the storage to both of the nodes of the PowerHA cluster. In the case of SAN storage, please ensure that your st... Read More
Setting new device attributes with chdef
Viewed 2100 times since Mon, Jun 3, 2019
While building a new LPAR recently I stumbled across the chdef command.  This command modifies the default value of a predefined attribute of the specified device type in the ODM (PdDv).  For devices that are already configured and of the same class,... Read More
Migrating from SDDPCM to AIXPCM (the easy way)
Viewed 2415 times since Mon, Jun 3, 2019
For a while now, IBM have diverted their efforts in storage multipathing from SDDPCM to the default AIX PCM [1]. This brings a few advantages, but specifically for me, it means the driver is now updated as part of the AIX system maintenance, and is ... Read More
This document discusses a new feature implemented for JFS2 filesystems to prevent simultaneous mounting.
Viewed 2705 times since Sat, Jun 1, 2019
Technote (FAQ) Question This document discusses a new feature implemented for JFS2 filesystems to prevent simultaneous mounting. Answer While AIX PowerHA can give concurrent access of volume groups to multiple systems, mounting a JFS2 filesystem on... Read More
Using AIX VG mirroring in combination with hardware snapshots
Viewed 4833 times since Sat, May 25, 2019
Using AIX VG mirroring in combination with hardware snapshots Posted on June 24, 2014 by Anthony Vandewerdt One of the great things about Logical Volume Managers is how you can use them for all manner of clever solutions.   I recently explored how ... Read More
AIX Changing ’defined’ or ’missing’ hard disk states to ’Available’ in IBM Smart Analytics System for AIX environment
Viewed 9286 times since Wed, May 22, 2019
Technote (troubleshooting) Problem(Abstract) Hard disks in 'defined' or 'missing' state should be changed to 'Available' state in IBM Smart Analytics System for AIX environment and disk settings need to be reconfigured.... Read More
AIX LVM QUORUM mysteries revealed
Viewed 3135 times since Wed, May 22, 2019
Technote (FAQ) Question Why can't I varyon a Volume Group when one or more physical volumes are not available? Cause Varyonvg requires 100% of its physical volumes be available and accessible in order to successfully vary on the Volume Group w... Read More
AIX↑ AIX www links
Viewed 3593 times since Sat, Apr 20, 2019
Links / URLs regarding IBM AIX: IBM.com - official website IBM Power Systems Technical documentation for AIX IBM System p Redbooks Domain Fix Central (including maintenance levels) Fix Level Recommendation Tool (FLRT) Inventory Scout - Microcode Dis... Read More
Topics: AIX, Networking, System Admin
Viewed 11378 times since Fri, Apr 19, 2019
As an AIX admin, you may not always know what switches a certain server is connected to. If you have Cisco switches, here's an interesting method to identify the switch your server is connected to. First, run ifconfig to look up the interfaces ... Read More
AIX, System Admin↑ The chrctcp command
Viewed 2926 times since Fri, Apr 19, 2019
The chrctcp command in not documented in AIX, but you can still use it to do nice things, especially when you are scripting. Some examples are: To enable xntpd in /etc/rc.tcpip, and to start xntpd: # chrctcp -S -a xntpd To disable xntpd in /etc/rc.t... Read More
AIX, Security, System Admin↑ Clearing password history
Viewed 2199 times since Fri, Apr 19, 2019
Sometimes when password rules are very strict, a user may have problems creating a new password that is both easy to remember, and still adheres to the password rules. To aid the user, it could be useful to clear the password history for his or her a... Read More
AIX, Security, System Admin↑ Fix user accounts
Viewed 4559 times since Fri, Apr 19, 2019
Security guidelines nowadays can be annoying. Within many companies people have to comply with strict security in regards to password expiration settings, password complexity and system security settings. All these settings and regulations more than ... Read More
AIX, Security, System Admin↑ Generating random passwords
Viewed 2859 times since Fri, Apr 19, 2019
When you set up a new user account, and assign a password to that account, you'll want to make sure that it is a password that can not be easily guessed. Setting the initial password to something easy like "changeme", only allows hackers easy ac... Read More
AIX, Security, System Admin Difference between sticky bit and SUID/GUID
Viewed 8804 times since Fri, Apr 19, 2019
This is probably one of things that people mess up all the time. They both have to do with permissions on a file, but the SUID/GUID (or SETUID short for set-user-id/SETGID short for set-group-id) bit and the sticky-bit are 2 completely different thin... Read More
AIX, Monitoring, System Admin↑ NMON recordings
Viewed 2883 times since Fri, Apr 19, 2019
One can set up NMON recordings from smit via: # smitty topas -> Start New Recording -> Start local recording -> nmon However, the smit panel doesn't list the option needed to get disk IO service times. Specifically, the -d option to col... Read More
AIX, Red Hat, Security, System Admin↑ System-wide separated shell history files for each user and session
Viewed 2121 times since Fri, Apr 19, 2019
Here's how you can set up your /etc/profile in order to create a separate shell history file for each user and each login session. This is very useful when you need to know who exactly ran a specific command at a point in time. For Red Hat Linux... Read More
AIX, Monitoring, Networking, Red Hat, Security, System Admin↑ Determining type of system remotely
Viewed 2100 times since Fri, Apr 19, 2019
If you run into a system that you can't access, but is available on the network, and have no idea what type of system that is, then there are few tricks you can use to determine the type of system remotely. The first one, is by looking at the T... Read More
AIX, Storage, System Admin↑ Identifying a Disk Bottleneck Using filemon
Viewed 9714 times since Fri, Apr 19, 2019
This blog will display the steps required to identify an IO problem in the storage area network and/or disk arrays on AIX. Note: Do not execute filemon with AIX 6.1 Technology Level 6 Service Pack 1 if WebSphere MQ is running. WebSphere MQ will abno... Read More
Topics: AIX, System Admin↑ Export and import PuTTY sessions
Viewed 2867 times since Fri, Apr 19, 2019
PuTTY itself does not provide a means to export the list of sessions, nor a way to import the sessions from another computer. However, it is not so difficult, once you know that PuTTY stores the session information in the Windows Registry. To export... Read More
AIX, Storage, System Admin Allocating shared storage to VIOS clients
Viewed 2144 times since Fri, Apr 19, 2019
The following is a procedure to add shared storage to a clustered, virtualized environment. This assumes the following: You have a PowerHA cluster on two nodes, nodeA and nodeB. Each node is on a separate physical system, and each node is a client of... Read More
AIX, System Admin Configuring dsh DSH
Viewed 3782 times since Fri, Apr 19, 2019
The dsh (distributed shell) is a very useful (and powerful) utility that can be used to run commands on multiple servers at the same time. By default it is not installed on AIX, but you can install it yourself: First, install the dsm file sets. DSM ... Read More
AIX www web Links
Viewed 3175 times since Fri, Apr 19, 2019
Links / URLs regarding IBM AIX: IBM.com - official website IBM Power Systems Technical documentation for AIX IBM System p Redbooks Domain Fix Central (including maintenance levels) Fix Level Recommendation Tool (FLRT) Inventory Scout - Microcode Di... Read More
AIX, Installation, NIM↑ Creating an LPP source and SPOT in NIM
Viewed 14509 times since Fri, Apr 19, 2019
This is a quick and dirty method of setting up an LPP source and SPOT of AIX 5.3 TL10 SP2, without having to swap DVD's into the AIX host machine. What you basically need is the actual AIX 5.3 TL10 SP2 DVD's from IBM, a Windows host, and a... Read More
AIX, Networking↑ Adding and deleting a static network route using the command line
Viewed 2495 times since Fri, Apr 19, 2019
There are two commands that can be used to add a route on an AIX system. The first one is route, and can be used to temporarily add a route to an AIX system. Meaning, if the system is rebooted, after the route has been added, the route will be lost ... Read More
How to Configure Sendmail not to Look up MX records
Viewed 3451 times since Fri, Apr 19, 2019
A default sendmail configuration will do DNS queries for MX records. It does this even when its setup to use a Mail Relay Server for sending mail out. This will cause mail to fail if its not able to lookup the MX record, for example when the SMTP rel... Read More
AIX, Networking Etherchannel failover testing
Viewed 2437 times since Fri, Apr 19, 2019
When an Etherchannel has been configured on AIX, using a primary and a backup adapter for failover purposes, it is possible to force a failover between these adapters. To do this, first check what the currently active adapter is within the Etherchan... Read More
AIX oslevel version OS
Viewed 4723 times since Wed, Apr 17, 2019
####oslevel -sqKnown Service Packs-------------------7200-02-02-1810 <---- BL TL ML YY WW ---> 7200 02 02 18 107200-02-02-18067200-02-01-17327200-02-01-17317200-02-00-00007200-01-04-18067200-01-03-17207200-01-02-17177200-01-01-16427200-00-06-18... Read More
Useful AIX general commands
Viewed 11646 times since Wed, Apr 17, 2019
Useful AIX commands svmon svmon -P <pid> Further: use can user svmon command to monitor memory usage as follows; (A) #svmon -P -v -t 10 | more (will give top ten processes) (B) #svmon -U -v -t 10 | more ( will give top ten use... Read More
NMON nmon
Viewed 11663 times since Tue, Apr 16, 2019
ScreenShots nmon for Linux Screen Shots On this webpage you can find Screen shots of using nmon for Linux online Sample graphs from the nmon Analyser after it generated them from nmon for Linux capture to a file Also see the nmonchart link on th... Read More
Changing Ethernet Media Speed for AIX
Viewed 3197 times since Tue, Apr 16, 2019
First you need to find out the device name of your ethernet card. It should be ent0 if the machine has only 1 ethernet card. Otherwise, it may be a higher number.You can determine the legal values for the media speed of the card by running the follow... Read More
A Unix Utility You Should Know About: lsof
Viewed 1843 times since Tue, Apr 16, 2019
A Unix Utility You Should Know About: lsof This is the third post in the article series about Unix and Linux utilities that you should know about. In this post I will take you through the useful lsof tool. If netcat was called the Swiss Army Knife... Read More
AIX Power replacing (hot-swap) failed disk in rootvg
Viewed 3523 times since Tue, Apr 16, 2019
  replacing (hot-swap) failed disk in rootvg After login in, I had to verify that it is indeed hdisk0 that died, 1 2 3 4 5 grdoras1:/root >  lsvg -p rootvg rootvg: PV_NAME   PV STATE  TOTAL PPs   FREE PPs    FREE DISTRIBUTION hdisk1 ... Read More
AIX- Procedure to replace rootvg harddisk
Viewed 4281 times since Tue, Apr 16, 2019
Procedure of replacing rootvg failed hdisk ================================= 1)Ensure all LV in VG are mirrored. (lsvg -l rootvg) 2) unmirrorvg rootvg hdisk1 ( eg for hdisk1 is failed) 3) Check for any more LV on the hdisk to be removed (lspv -l hdis... Read More
Remove disk from volumegroup in AIX
Viewed 6533 times since Tue, Apr 16, 2019
Sometimes in a migration project you need to temporary add extra disks to volume group. As a storage admin you like get the disks back when your colleagues are finished migrating the application. I tried to create a clear procedure to get this done.U... Read More
AIX Commands Related to Boot and Init Process
Viewed 4389 times since Tue, Apr 16, 2019
AIX Commands Related to Boot and Init Process Posted on November 21, 2012 by ksgnathan 1) To find the run-level in which system is working a) #who -r b) cat /etc/.init.state 2) To change the runlevel from one to other #telinit  M  or shutdown -m  –... Read More
AIX Booting
Viewed 10101 times since Tue, Apr 16, 2019
Startup - Shutdown mkitab                     adds record to the /etc/inittab file (-i: insert the newline anywher in the inittab file)                            (without the -i parameter, the line wil be appended to the end of the file) lsitab   ... Read More
AIX boot proccess
Viewed 2819 times since Tue, Apr 16, 2019
AIX Boot Process POWER ON POST (Power on Self Test) / BIST (Built-in Self Test for AIX) ROS Initialization (Checks Mother Board using OCS BUMP) Hardware ROS                                                Software ROS                                  ... Read More
bootlist multiple boot logical volume found
Viewed 2608 times since Tue, Apr 16, 2019
This describes how to resolve the following error when setting the bootlist: # bootlist -m normal hdisk2 hdisk3 0514-229 bootlist: Multiple boot logical volumes found on 'hdisk2'. Use the 'blv' attribute to specify the one from w... Read More
Recovery from LED 552, 554, or 556 in AIX
Viewed 2467 times since Tue, Apr 16, 2019
Recovery from LED 552, 554, or 556 in AIX   Technote (FAQ) Question Recovery from LED 552, 554, or 556 system hang conditions in AIX. Answer This document discusses the known causes of LED 552, 554, and 556. Included is a procedure for rec... Read More
My LPAR always boots into SMS. Why?
Viewed 3481 times since Tue, Apr 16, 2019
If you turn on Multiboot from within the SMS menu (as shown below), your LPAR will always boot into SMS, regardless of your AIX boot list and/or LPAR profile settings.    PowerPC Firmware Version EM310_048 SMS 1.6 (c) Copyright IBM Corp. 2000,2005 Al... Read More
Getting bosboot errors, don’t reboot just yet
Viewed 2755 times since Tue, Apr 16, 2019
Introduction In this demonstration, I will be using hdisk0 in the examples provided. The checks I provide are not an exhaustive list, but rather common issues I have come across over the years. When getting bosboot errors, I always find it best to go... Read More
AIX Reviewing AIX Error and Boot Logs
Viewed 2646 times since Wed, Mar 20, 2019
Reviewing AIX Error and Boot Logs   July 2013 | by David Tansley   Print 5     AIX provides comprehensive logging of events—some are errors requiring attention and others are just notifications. For system administrators, tasked to mak... Read More
AIX Errpt - Diag - Alog
Viewed 3429 times since Wed, Mar 20, 2019
ERROR LOGGING: The errdemon is started during system initialization and continuously monitors the special file /dev/error for new entries sent by either the kernel or by applications. The label of each new entry is checked against the contents of th... Read More
0516-787 extendlv: Maximum allocation for logical volume error
Viewed 8531 times since Tue, Mar 12, 2019
Sometimes you will see this error when you want to extend filesystem / logical volume. Error Message:  0516-787 extendlv: Maximum allocation for logical volume <LV_Name> is 512. Maximum number of LPs for the logical volume has been exceeded – ... Read More
AIX -- extending Logical Volumes online
Viewed 2597 times since Tue, Mar 12, 2019
AIX -- extending Logical Volumes online   In this post, we will extend an Logical Volume size in AIX system. The AIX system used in this example, is AIX 5.3. The operation is online, and the effects of it can be seen instantaneously. We use commands... Read More
Oslevel shows wrong AIX’s level. Why
Viewed 4597 times since Thu, Feb 21, 2019
Sometimes we see our AIX box with a lower oslevel than it really have. Why? This is due to filesets with a lower level than the system have. What happened? Let explain that with an example. Today I have installed AIX 7.1 TL3 SP1 on my box. ‘osl... Read More
Install and configure yum on AIX
Viewed 4429 times since Thu, Feb 21, 2019
Prerequisites: Download latest version of RPM file from https://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/INSTALLP/ppc/ and copy it to /tmp/yum/rpm/ directory on AIX system. Download latest version of yum_bundle (yum_bundle_v1.tar) from https... Read More
Setup private yum repository for AIX clients
Viewed 10960 times since Thu, Feb 21, 2019
Prerequisites:   A Unix server on your private network: Accessing IBM repository ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/)    Apache server installed to serve RPM files for internal AIX clients.    AIX clients must access this... Read More
Reconfigure RSCT ID to fix DLPAR issues on cloned AIX systems
Viewed 13498 times since Thu, Feb 21, 2019
ON AIX systems, RMC daemons are part of the Reliable, Scalable Cluster Technology (RSCT). They allows the HMC to communicate with a managed logical partition to do DLPAR operations. But, when we clone an AIX system, for example using mksysb, RSCT ID ... Read More
AIX hangs on boot? How to debug boot process on AIX systems
Viewed 9868 times since Thu, Feb 21, 2019
Today an AIX system hanged when reboot. What’s going on? Where can I see the debug verbose log of boot process? Just, follow this steps. 1- Boot AIX LPAR from HMC in “Open firmware OK prompt”mode: 2- Connect ssh to HMC/FSM with user hscroot a... Read More
Recovery AIX system when hang on boot (554 code error).
Viewed 15648 times since Thu, Feb 21, 2019
If AIX system does not boot properly, possible causes could be: corrupted file system corrupted Journaled File System (JFS) log device bad IPL-device record or bad IPL-device magic number; the magic number indicates the device type corrupted copy of... Read More
DISK OPERATION ERROR in AIX
Viewed 13812 times since Thu, Feb 21, 2019
Last month, we noted errpt showing an error: 1 2 3 4 5 6 7 8 9 10 11 [root@aix:/] errpt -a IDENTIFIER TIMESTAMP  T C RESOURCE_NAME  DESCRIPTION DCB47997   1122091816 T H hdisk29        DISK OPERATION ERROR F31FFAC3   1122091816 I H hdisk29  ... Read More
Working with Virtual media library on VIO servers
Viewed 14578 times since Thu, Feb 21, 2019
Sometimes we need to map an ISO images to LPARs. Today we’re going to create a VM library, load ISO images and map them to LPARs. Just follow these steps Prerequisites: Download AIX’s iso files from IBM entitled software support. Copy IS... Read More
Create memory resident filesystems (RAM disk) on AIX
Viewed 2562 times since Thu, Feb 21, 2019
AIX supports memory-resident file systems. It can be used to maximize disk performance. It’s equivalent to Solaris tmpfs filesystem. NOTE: RAM disk doesn’t survive a reboot. Steps to create a RAM disk on AIX: Get size of real (online) me... Read More
Calculate hdisk READ / WRITE throughput (sequential IO) from AIX systems
Viewed 2518 times since Thu, Feb 21, 2019
Do you know the throughput of your disks? This time we’re going to calculate read / write throughput of hdisks from an AIX system. Let’s create a file for this test. 1 [root@aix:/] lptest 127 32 > /tmp/file 1 2 ... Read More
Script to download TL and SP for AIX using NIM and SUMA
Viewed 8985 times since Thu, Feb 21, 2019
Well, we know IBM’s fix central exists and you can register and download any Tls, SPs or efixes among tons of important information but sometimes it is slow, difficult to download it. So, using a tool from IBM known as S.U.M.A (Service Update M... Read More
Script to reset NIM state and deallocate resources
Viewed 2245 times since Thu, Feb 21, 2019
Sometimes we need to reset the state of a lpar on our NIM server. You can use smitty, but it’s simpler to use a shell script. First, we check the which NIM resources our LPAR has inside NIM: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 ... Read More
Check connection (rsh or nimsh) between NIM server and LPAR
Viewed 9959 times since Thu, Feb 21, 2019
NIM server needs to be connected with LPARs, either using rsh or nimsh protocol. In case this communcation is lost, mksysb backups or other tasks from NIM to this lpar will fail. So, I have made this simple script to check this connectivity between N... Read More
Script to make mksysb backup from NIM to LPAR
Viewed 3516 times since Thu, Feb 21, 2019
Make mksysb backup for your rootvg to NIM is very important. It can save your life sometimes Read More
How do I analyze and debug core files on AIX
Viewed 6076 times since Thu, Feb 21, 2019
Sometimes, applications stop working and crash for any reason. A core file appears in scene. First, we’re going  to set a PATH for all cores files on the system  using syscorepath command. In order to do this, We’re going to: 1- Create an... Read More
Authenticate AIX using MS DC’s kerberos servers (Active Directory)
Viewed 2073 times since Thu, Feb 21, 2019
In your environment, it’s critical for auditors to have only one centralized source of users/passwords. There are tons of ways AIX can do this. The way I use is using Windows active directory’s kerberos servers. Here’s what I do: 1-... Read More
Install and configure GNU’s screen on AIX
Viewed 8695 times since Thu, Feb 21, 2019
Sometimes we have only one terminal to an AIX system and we need to open multiples logins to make parallel tasks. This is where GNU screen (http://www.gnu.org/software/screen/) comes to play.  I use ‘GNU screen’ also tu run a long tasks i... Read More
SSH-COPY-ID on AIX. SSH remote AIX’s box without password
Viewed 16412 times since Thu, Feb 21, 2019
I’m sure most unix administrators knows the utility ‘ssh-copy-id’  part of OpenSSH. It’s very useful when we need to exchange SSH keys between hosts. This simple shell script is available on most Linux distros, but it’s ... Read More
Monitor logfiles and command output on AIX using multitail.
Viewed 2170 times since Thu, Feb 21, 2019
Most applications, like operating systems, have their own logs files. Sometimes, we need to see them at the same time to troubleshoot issues. Here’s when multitail (http://www.vanheusden.com/multitail/) can help us. This tool can be installed o... Read More
Install and configure GNU watch (gwatch) on AIX
Viewed 7642 times since Thu, Feb 21, 2019
GNU’s Linux have an interesting command ‘GNU watch’ http://linux.die.net/man/1/watch which its main function is not to watch your wife while you’re at work (Just kidding), its function is to  execute a program periodically, sh... Read More
Mirroring session (TTY) on AIX using portmir
Viewed 9179 times since Thu, Feb 21, 2019
Sometimes we want to see the screen of the session of another user in, order to solve any problem remotely. Portmir is an interesting AIX’s command and help us to achieve this. Portmir is part of bos.sysmgt.serv_aid filand filesetis and it&rsqu... Read More
Find out which port the daemon is using on AIX OS. (similar like command netstat -anp for Linux)
Viewed 11142 times since Thu, Feb 21, 2019
How to find which port TCP or UDP are being used by daemons on AIX OS. For TCP protocol: netstat -Aan |grep -E "\*.[0-9].+LISTEN" |awk  '{print $1, substr($5,3)}' |while read socket port do   echo "TCP Ports: " $port "--->" $(rmsock ... Read More
Configure log file for cron daemon on AIX
Viewed 10337 times since Thu, Feb 21, 2019
Cron daemon log in by default on /var/adm/cron/log, but I wanted to put it with all other logs of the system. All system logs (syslog, mksysb, ftp, http, and so on, are on /var/syslog filesystem, I decided to put cron logs in the same place. Here&rsq... Read More
Ethernet tunning for VIOS and AIX for 10 Gib/sec environtement.
Viewed 10208 times since Thu, Feb 21, 2019
I had the pleaseure to setup from scratch an IBM pureflex p270 system, including chassis, ethernet switches, fiber channel switches, FSM, dual VIOS and LPARs. Although, all connections inside pureflex node is at 10 Gbits/sec, this chassis is connecte... Read More
Create jfs2 logical volume on AIX
Viewed 4510 times since Thu, Feb 21, 2019
How to create a jfs2 logical volume on AIX? First, you need to know: Which volume group you’re going to create the LV. In our case ‘newvg’ [root@aix:/] lsvg -o rootvg newvg Volume group PP size. In our case ‘4MB’ [r... Read More
Create volume groups on AIX - Normal Big Scalable
Viewed 6561 times since Thu, Feb 21, 2019
You can create three types of volume groups on AIX: Normal Big Scalable VG type      Max-PVs      Max-LVs         Max-PPs per VG         Max-PP per size Normal          32           256              32,512                    1 GB Big            128... Read More
AIX: Error code 0516-1339, 0516-1397 0516-792: cannot extendvg with a previous Oracle ASM disk
Viewed 3532 times since Wed, Feb 6, 2019
Error Message: labserver:/root# extendvg -f backupvg hdisk1 0516-1339 extendvg: Physical volume contains some 3rd party volume group. 0516-1397 extendvg: The physical volume hdisk1, will not be added to the volume group. 0516-792 extendvg: Unable to ... Read More
Writing a Custom PVID
Viewed 2794 times since Fri, Feb 1, 2019
Writing a Custom PVID John.Wright | June 14 2012 | Visits (10497)   This blog post came about after a customer had encountered a problem on AIX 5.3.  The disk being imported is a floating SAN disk shared between servers on various frames.  T... Read More
Aix: How to assign a specific PVID
Viewed 7020 times since Fri, Feb 1, 2019
Aix: How to assign a specific PVID July 28, 2009 admin Leave a comment 1) BACKUP old disk critical data. # dd if=/dev/hdisk9 of=/tmp/hdisk9.save bs=4k count=1   If something were to go wrong and the head information got damaged use the following ... Read More
Got Duplicate PVIDs in Your User VG? Try Recreatevg!
Viewed 3141 times since Fri, Feb 1, 2019
Got Duplicate PVIDs in Your User VG? Try Recreatevg!   June 2016 | by David Tansley   Print 3     I recently installed a new SP (service pack) level on AIX. I then rebooted the box, as is usual practice for the changes to take effect. But up... Read More
Creating Normal,Big,Scalable VG on AIX
Viewed 14507 times since Fri, Feb 1, 2019
      Tuesday, 17 July 2012   Creating Normal,Big,Scalable VG on AIX   After SAN team assigned Disks/LUNs to the server,we need to scan it from OS side and once scanned completed successfully and disks are available we will be able to c... Read More
A Change to the SMT Mode Default in POWER9
Viewed 5120 times since Fri, Jan 18, 2019
October 30, 2018 There's a rather significant change with the default SMT mode in AIX 7.2 TL3 running on POWER9 servers: “For POWER9 technology-based servers, the default SMT setting for AIX 7.2 TL 3 has been changed to SMT8 to provide the best ... Read More
AIX smtctl The smtctl command controls the enabling and disabling of processor simultaneous multithreading mode.
Viewed 14881 times since Fri, Jan 18, 2019
Description This command is provided for privileged users and applications to control utilization of processors with simultaneous multithreading support. The simultaneous multithreading mode allows processors to have thread level parallelism at the i... Read More
AIX ODM for MPIO User Guide 09
Viewed 3803 times since Mon, Dec 31, 2018
This chapter provides answers to frequently asked questions (FAQs) during AIX ODM for MPIO configuration and management. You can refer to this chapter for troubleshooting if necessary. 7.1 What Are Known Bugs That Affect This Software and Corresp... Read More
AIX Migrating from SDDPCM to AIXPCM (the easy way)
Viewed 19724 times since Mon, Dec 31, 2018
Migrating from SDDPCM to AIXPCM (the easy way) Posted on July 30, 2018 For a while now, IBM have diverted their efforts in storage multipathing from SDDPCM to the default AIX PCM [1]. This brings a few advantages, but specifically for me, it means... Read More
AIX Net How to check VLAN ID number on AIX?
Viewed 15244 times since Thu, Nov 29, 2018
To check VLAN ID on AIX you can issue the command entstat filtering the result as the follow: # entstat -d en0 | grep 'Port VLAN ID' Port VLAN ID: 800 hostname:/:$ lsdev | grep ^ent ent0 Available Virtual I/O Ethernet... Read More
How to enable Large Pages for a specific user on AIX?
Viewed 2305 times since Thu, Nov 29, 2018
# chuser capabilities=CAP_BYPASS_RAC_VMM,CAP_PROPAGATE USER_ID Read More
How to build a NIM Server on AIX 6.1 from the Scratch :: Part 1
Viewed 4765 times since Thu, Nov 29, 2018
How to build a NIM Server on AIX 6.1 from the Scratch :: Part 1 May 23, 2017Leave a comment Hello Fellas! Here is a good how to build from the Scratch a NIM Server under AIX 6.1. (The operation for version 7.1 stills the same, anyway). Well, for t... Read More
How to clear/clean/erase/delete/reset network adapter configuration on AIX?
Viewed 12281 times since Thu, Nov 29, 2018
To reset, clear, clean or erase network adapter configuration that means, IP Address and Netmask, issue the following command: # chdev -a netaddr=0.0.0.0 -a netmask=0.0.0.0 -l en0 Read More
Trick to Purge/Clean Swap Usage on AIX
Viewed 7582 times since Thu, Nov 29, 2018
Trick to Purge/Clean Swap Usage on AIX May 13, 2017Leave a comment And, “of course” after solving what was using to much swap space, you got already a good space that needs to be free, well, we’re here to do the trick! # lsps -a Page Space ... Read More
Script to show Total, Free and Used Memory on AIX
Viewed 3272 times since Thu, Nov 29, 2018
Just Copy and Paste: (memory=`prtconf -m | awk 'BEGIN {FS=" "} {print $3/1024}'` usedmem=`svmon -G | grep memory | awk 'BEGIN {FS=" "} {print $3/256/1024}'` freemem=`echo $memory-$usedmem | bc -l` clear echo echo "Memory Results:"... Read More
Awesome Command to show top 15 processes using memory on AIX
Viewed 23618 times since Thu, Nov 29, 2018
Need to know who is on the top processes using memory on AIX?, here is: Command: # svmon -Pt15 | perl -e 'while(<>){print if($.==2||$&&&!$s++);$.=0 if(/^-+$/)}' Output: # svmon -Pt15 | perl -e 'while(<>){print i... Read More
How to know witch process is running in a particular port on AIX using KDB
Viewed 12483 times since Thu, Nov 29, 2018
How to know witch process is running in a particular port on AIX using KDB May 13, 2017Leave a comment Fellas, here is the gig, please, don’t cry! Read More
AIX lspath Missing path
Viewed 9428 times since Fri, Oct 5, 2018
Reviewing disk paths, I found some paths showing as Missing and some enabled on the same fscsi root@aix:/ # lspath -l hdisk31 Enabled hdisk31 fscsi0 Missing hdisk31 fscsi0 Enabled hdisk31 fscsi0 Missing hdisk31 fscsi0 Enabled hdisk31 fscsi2 Missing ... Read More
Checking HBA status on AIX
Viewed 17805 times since Fri, Oct 5, 2018
Checking HBA status on AIX By Emerson Takahashi on March 2, 2018 Storage team checked and it was not showing light on the fiber Index Slot Port Address Media Speed State Proto =================================================== 298 3 42 28a280 id N... Read More
Changing ’defined’ or ’missing’ hard disk states to ’Available’ in IBM Smart Analytics System for AIX environment
Viewed 2275 times since Thu, Sep 20, 2018
Problem(Abstract) Hard disks in 'defined' or 'missing' state should be changed to 'Available' state in IBM Smart Analytics System for AIX environment and disk settings need to be reconfigured. Resolving the problem The ... Read More
replacing (hot-swap) failed disk in rootvg
Viewed 8887 times since Thu, Sep 20, 2018
IBM called me because one of my hosts called them reporting a failed disk in rootvg. It was the hdisk0 that decided to quit. A few minutes later, a service engineer called my to let me know that he is driving with the new disk. I had about an hour to... Read More
List AIX File Systems the Easy Way With the lsvgfs Command
Viewed 1888 times since Thu, Sep 20, 2018
List AIX File Systems the Easy Way With the lsvgfs Command   March 2016 | by Anthony English   Print 0   Resources Even for an IT guy, having a favorite AIX command seems pretty geeky. Nonetheless, I do have one. It’s the lsvgfs co... Read More
Practical Guide to AIX - network
Viewed 17397 times since Thu, Sep 20, 2018
Network netstat -i            shows statistic of all defined network interfaces (the * at the name means currently inactive)                       if Oerrs greater than 1% of Opkts -> xmt_que_size (send queue size) should be increased           ... Read More
Manages processor scheduler tunable parameters schedo AIX
Viewed 2465 times since Thu, Sep 20, 2018
Manages processor scheduler tunable parameters. Syntax schedo [ -p | -r ] [-y] { -o Tunable[= Newvalue]} schedo [ -p | -r ] [-y] { -d Tunable } schedo [ -p | -r ] [-y] -D schedo [ -p | -r ] [ -F] -a schedo -h [Tunable ] schedo [-F] -L [Tunable ] s... Read More
Burn Image to DVD in AIX
Viewed 13292 times since Thu, Sep 20, 2018
Burn Image to DVD in AIX   Burn Image to DVD there are two ways to restore a mksysb file.  One is to use NIM, the other is to burn the mksysb image onto DVD.   This was the copying a mksysb image to a DVD or creating an ISO image with the entire DV... Read More
AIX 0516-404 allocp: This system cannot fulfill the allocation
Viewed 3209 times since Thu, Sep 20, 2018
emre@sysaix:/ # chfs -a size=+1G /dizin 0516-404 allocp: This system cannot fulfill the allocation request. There are not enough free partitions or not enough physical volumes to keep strictness and satisfy allocation requests. The c... Read More
0516-404 allocpThis system cannot fulfill the allocation
Viewed 9911 times since Thu, Sep 20, 2018
While trying to increase space on one of my file systems I get the following error, Code: [/home/root] #chfs -a size=+5G /fns/ld/r 0516-404 allocp: This system cannot fulfill the allocation request. There are not enough free partit... Read More
0516-404 allocp: This system cannot fulfill the allocation request. [AIX]
Viewed 4975 times since Thu, Sep 20, 2018
0516-404 allocp: This system cannot fulfill the allocation request. [AIX]     Hello all, today I’m going to talk about an error that I have faced today during I was trying to increase a filesystem/Logical Volume : hostname # chfs -a size=+1G... Read More
AIX snap - Prevent dump collection
Viewed 12176 times since Mon, Sep 17, 2018
You can specify the –Z flag with the AIX snap command to prevent it from collecting system dump data. The flag is not shown in the man page for snap. However, it is listed in the usage information.   # oslevel -s 7100-03-03-1415   # sysdumpdev -L    ... Read More
SNAP
Viewed 1844 times since Mon, Sep 17, 2018
SNAP: It gathers system configuration information and compresses the information to a pax file. This file can be downloaded later to a tape or a cd or can be sent to a remote system. This SNAP information is later used by IBM to resolve real time pro... Read More
SNAP in AIX
Viewed 11351 times since Mon, Sep 17, 2018
SNAP in AIX   Before running a snap .You need to Remove  old snap file. # snap -r   For IBM Software Case. Below command collect all the information. # snap -ac   For IBM Hardware Case # snap -gc snap  without  dump collection # snap -aZc # s... Read More
AIX perf how to
Viewed 18539 times since Tue, Aug 14, 2018
Run for 10 minutes / 600 seconds. The perfpmr run should be     captured while the system is affected by the performance issue.     The perfPMR script is being updated on a regular basis.     Please complete the questions asked in the PROBLEM.INFO ... Read More
AIX How to Investigate a System Reboot
Viewed 6295 times since Tue, Aug 14, 2018
Technote (FAQ) Question Why did AIX shut down and reboot, or shut down and halt? Answer Introduction How does a system go down? How does a system boot up after going down? What system logs and commands can I use to investigate an unexpected shut do... Read More
AIX Replacing a failed disk (rootvg)
Viewed 8344 times since Tue, Jul 17, 2018
Replacing a failed disk (rootvg) This post will describe the replacement of a failed rootvg disk. In short the procedure is the following: 1. unmirrorvg rootvg hdisk0 (savebase -v) 2. reducevg rootvg hdisk0 3. rmdev -Rdl hdisk0 4. diag (safely remo... Read More
Create a mksysb + SPOT using NIM (CLI)
Viewed 5459 times since Tue, Jul 17, 2018
Create a mksysb + SPOT using NIM (CLI) Here I will describe how to create a mksysb image of a NIM client from the NIM server using the cli and afterwards we will create a SPOT from the newly created mksysb. So firt we define the new mksysb: # nim -... Read More
AIX Increase paging space logical volume size
Viewed 2762 times since Tue, Jul 17, 2018
Increase paging space logical volume size To show the current paging space volume, its size along with other information use the ‘lsps’ command: #lsps -a Page Space Physical Volume Volume Group Size %Used Active Auto Type Ch... Read More
AIX Undocumented AIX command lquerypv
Viewed 3458 times since Tue, Jul 17, 2018
Undocumented AIX command lquerypv lquerypv can read the PVID directly from the disk: # lquerypv -h /dev/hdisk0 80 10 00000080 00C4489D 5E6002A5 00000000 00000000 |..H.^`..........| # lspv hdisk0 00c4489d5e6002a5 root... Read More
AIX Creating a Volume Group
Viewed 2379 times since Tue, Jul 17, 2018
Creating a Volume Group This post will describe how to: 1. Create a Volume Group 2. Create a Logical Volume within the VG containing a JFS2 filesystem that will be automatically mounted during boot. 3. Add a disk to the VG and mirror the data acros... Read More
Installing a Interim Fix (APAR IV16587)
Viewed 2800 times since Tue, Jul 17, 2018
Installing a Interim Fix (APAR IV16587) This post will describe a interim Fix installation from the APAR IV16587 on a system level 6100-07-02-1150, more information  can be found here, more about Interim fixes in general is here. This procedure wil... Read More
AIX Not all filesets for 6100-07_AIX_ML were found
Viewed 2825 times since Tue, Jul 17, 2018
Not all filesets for 6100-07_AIX_ML were found After os level update it might happen that not all filesets are installed correctly what results in a lower oslevel than we attempted to update to. For example if we update from TL5 to TL7 on AIX 6.1. ... Read More
Mount CD/DVD & ISO image in AIX 6.1
Viewed 3872 times since Tue, Jul 17, 2018
Mount CD/DVD & ISO image in AIX 6.1 To mount a CD or DVD from the CLI use: # mount -V cdrfs -o ro /dev/cd0 /mnt # df -g /mnt Filesystem GB blocks Free %Used Iused %Iused Mounted on /dev/cd0 3.64 0.00 100% 1905950 1... Read More
List STALE partitions across Volume Groups for each Logical Volume in AIX
Viewed 2386 times since Tue, Jul 17, 2018
List STALE partitions across Volume Groups for each Logical Volume in AIX I wrote a tiny script that can report the number of stale partitions across multiple Volume Groups. If invoked with the -a flag the script will list LPs, PPs and Stale partit... Read More
AIX NTP Client configuration
Viewed 11730 times since Tue, Jul 17, 2018
NTP Client configuration To configure a AIX box as a NTP client first set the correct time zone using `smitty chtz_date`. Also set the system time manually as accurate as possible, if the system time would be way out of the reality, the xntpd daemo... Read More
IP configuration in AIX
Viewed 2591 times since Tue, Jul 17, 2018
IP configuration in AIX Here are some TCP/IP related commands, might be usefull. Generally by using ifconfig and route commands your settings will not be preserved after the reboot, because the settings will not be stored in the ODM. So to make the... Read More
AIX Assign a PVID to a new hdisk
Viewed 6392 times since Tue, Jul 17, 2018
Assign a PVID to a new hdisk Very simple: # lspv hdisk0 00c0e90dce6c290a rootvg active hdisk1 none None hdisk2 none ... Read More
View mksysb content & restore individual files
Viewed 1713 times since Tue, Jul 17, 2018
View mksysb content & restore individual files To view information about a mksysb backup file use: Display info about VG backup | # lsmksysb -lf P2_1202_TL7.mk | | | Mks... Read More
AIX Encrypted File System
Viewed 5652 times since Tue, Jul 17, 2018
Encrypted File System This post will in short describe how to setup an Encrypted Filesystem on AIX 6.1. EFS offers 2 modes of operation: Root Admin mode This is the default mode. Root can reset user and group keystore passwords. Root Guard mode Roo... Read More
Create bootable DVD iso image from a mksysb backup
Viewed 4311 times since Tue, Jul 17, 2018
Create bootable DVD iso image from a mksysb backup If for any reason necessary, you can create a bootable DVD.iso file from a mksysb backup, using mkcd: Create CD/DVD image | mkcd -L -S -I /mksysb/bootable_mk -m /mksysb/my_mksysb_backup... Read More
Undocumented AIX command lquerypv
Viewed 3460 times since Mon, Jul 16, 2018
lquerypv can read the PVID directly from the disk: # lquerypv -h /dev/hdisk0 80 10 00000080 00C4489D 5E6002A5 00000000 00000000 |..H.^`..........| # lspv hdisk0 00c4489d5e6002a5 rootvg active And also the... Read More
How to Investigate a System Reboot
Viewed 4441 times since Mon, Jul 16, 2018
How to Investigate a System Reboot Technote (FAQ) Question Why did AIX shut down and reboot, or shut down and halt? Answer Introduction How does a system go down? How does a system boot up after going down? What system logs and commands can I use t... Read More
AIX Full memory dump configure
Viewed 3267 times since Mon, Jul 16, 2018
#oslevel -s 6100-03-00-0000 #lsattr -El mem0 ent_mem_cap         I/O memory entitlement in Kbytes           False goodsize       4096 Amount of usable physical memory in Mbytes False size           4096 Total amount of physical memory in Mbytes  Fa... Read More
AIX PDF ALL
Viewed 6397 times since Mon, Jul 16, 2018
http://ps-2.kev009.com/basil.holloway/ALL%20PDF/ Read More
Firmware Assisted Dump sysdump
Viewed 1852 times since Mon, Jul 16, 2018
Firmware Assisted Dump   Firmware Assisted Dump     Technote (FAQ) Question This document describes the firmware assisted dump option for AIX system dumps. Answer The firmware assisted dump option was added in AIX 6.1 to improve the syste... Read More
sysdumpdev Command
Viewed 1702 times since Mon, Jul 16, 2018
Purpose Displays and modifies the information and settings that are related to traditional system dump and firmware-assisted system dump. Syntax sysdumpdev -P { -p device | -s device } [ -q ] [ -i ] sysdumpdev [ -p device | -s device ] [ -q ] sys... Read More
How to determine why your AIX oslevel is downlevel (and a script to help!)
Viewed 3867 times since Fri, Jul 13, 2018
How to determine why your AIX oslevel is downlevel (and a script to help!) o determine the oslevel on AIX, you can run the "oslevel -s" command.   However, what "oslevel -s" reports doesn't always show the entire picture.   The OS level reported... Read More
Managing System Dump Devices sysdumpdev
Viewed 3296 times since Mon, Jul 9, 2018
  Managing System Dump Devices Technote (FAQ) Question Managing System Dump Devices Answer   This document discusses how to manage storage devices used by AIX to store a system dump in the event of a catastrophic operating system software failure. ... Read More
Understanding dump devices sysdumpdev
Viewed 4406 times since Mon, Jul 9, 2018
If your system crashes due to an unexpected event, it core dumps. In fact a core dump can occur without a crash. However, for this article I assume that the system goes down due to a fatal event or via a user's forced action. The dump contains c... Read More
Problem on resizing volume group on AIX 0516-1714, 0516-792, 0516-787, and 0516-404
Viewed 2435 times since Fri, Jul 6, 2018
Problem on resizing volume group on AIX 0516-1714, 0516-792, 0516-787, and 0516-404 Check MAX PPs per VG:     131072  This is tested on AIX 6.1. When you try to add a disk to an existing VG, by doing: #extendvg vgdata hdisk20 you may receive the fo... Read More
AIX 6.1: Extend VG 0516-1714 extendvg 0516-1254 extendvg
Viewed 4374 times since Fri, Jul 6, 2018
AIX 6.1: Extend VG  0516-1714 extendvg  0516-1254 extendvg   AIX 6.1: Extend VG   extendvg   In case error wrt PPs: like:  0516-1254 extendvg: Changing the PVID in the ODM. 0516-1714 extendvg: The total number of partitions on the disks for this     ... Read More
SSH Essentials: Working with SSH Servers, Clients, and Keys
Viewed 4163 times since Wed, Jun 27, 2018
Introduction SSH is a secure protocol used as the primary means of connecting to Linux servers remotely. It provides a text-based interface by spawning a remote shell. After connecting, all commands you type in your local terminal are sent to the re... Read More
O’Reilly’s CD bookshelf
Viewed 11925 times since Wed, Jun 27, 2018
https://docstore.mik.ua/orelly/bookshelfs.html   The Java Reference Library, version 1.3 The Java Enterprise CD Bookshelf, Version 1.0 The Perl CD Bookshelf, version 1.0 ... Read More
AIX NFS Version 4 configuration over Kerberos inter-realm setup
Viewed 3810 times since Wed, Jun 27, 2018
AIX NFS Version 4 configuration over Kerberos inter-realm setup Prashant Sodhiya and Sandeep PatilPublished on January 08, 2008 FacebookTwitterLinked InGoogle+E-mail this page 0 Since security is one of the key aspects and selling ... Read More
Using Kerberos security with Server for NFS
Viewed 9272 times since Wed, Jun 27, 2018
Using Kerberos security with Server for NFS May 13, 2010 by JoseBarreto // 1 Comments Share 0 0 I’ll discuss how to configure a UNIX based NFS client to connect to Windows Server for NFS using Kerberos security with RPCSEC_GSS. Traditionally ... Read More
Kerberos, Active Directory and AIX
Viewed 6174 times since Mon, Jun 25, 2018
Print 0     Kerberos, Active Directory and AIX   May 2014 | by Mark Duszyk   Print 0     You can find a lot and often conflicting information on the subject of using Kerberos with Active Directory to authenticate AIX clients. Recently... Read More
Kerberos authentication configuration for AIX servers
Viewed 10700 times since Mon, Jun 25, 2018
Kerberos authentication configuration for AIX servers Kerberos authentication configuration for AIX servers This document describes how to configure Kerberos authentication on AIX 5.3, 6.1 and 7.1 working with Windows 2008 R2 Active Directory serve... Read More
Software management in AIX
Viewed 6669 times since Mon, Jun 25, 2018
Software management in AIX Software management in AIX leave a comment » Fileset in AIX is named for softwares or dependencies. Group of filesets is called a package. For eg: bos.net is a package and bos.net.nfs.client is a fileset. BOS stands for Ba... Read More
Configuring an AIX client with multiple Kerberos realms
Viewed 8712 times since Mon, Jun 25, 2018
Configuring an AIX client with multiple Kerberos realms Shruthi Sharma and Uma ChandoluPublished on October 20, 2009 FacebookTwitterLinked InGoogle+E-mail this page 2 Overview Kerberos is a network authentication protocol based on ... Read More
Epoch & Unix Timestamp Conversion Tools
Viewed 48800 times since Fri, Jun 22, 2018
The current Unix epoch time is  1529656113   Convert epoch to human readable date and vice versa  [batch convert timestamps to human dates] GMT: Friday, 22 June 2018 07:40:23Your time zone: piątek, 22 czerwca 2018 09:40:23 GMT+02:00 DST Yr Mon D... Read More
Do you Know These 5 Use of V$session View ?
Viewed 100585 times since Thu, Jun 21, 2018
Do you Know These 5 Use of V$session View ?     V$session view is the base of all information related to current system status like which user, How many session, Which query and how long query is waiting etc. V$session is the first place when DBA s... Read More
List of 10 Must Know Oracle Database Parameters for Database Administrator
Viewed 117092 times since Thu, Jun 21, 2018
List of 10 Must Know Oracle Database Parameters for Database Administrator     Database Parameters are environment variables for a database which can change database behavior according to value of the parameter. These are input values which are tak... Read More
What is OS Watcher Utility and How to use it for Database Troubleshooting ?
Viewed 29752 times since Thu, Jun 21, 2018
What is OS Watcher Utility and How to use it for Database Troubleshooting ?     Oracle OS Watcher (OSWatcher) is a tool to help Remote DBA's to trouble shoot Database performance, Cluster reboot, node eviction, DB server reboot, DB instance Cr... Read More
How to Analyze or Read OS Watcher Output in three easy steps -- With Example ?
Viewed 40900 times since Thu, Jun 21, 2018
How to Analyze or Read OS Watcher Output in three easy steps -- With Example ?     I assume, you have got Oracle OS Watcher (OSWatcher) logs and Database Administrator is facing slow database performance or System hang kind of situations. So, Next ... Read More
Top 4 Reasons for Node Reboot or Node Eviction in Real Application Cluster (RAC) Environment
Viewed 82425 times since Thu, Jun 21, 2018
Top 4 Reasons for Node Reboot or Node Eviction in Real Application Cluster (RAC) Environment Remote DBA usually face Node Reboots or Node Evictions in Real Application Cluster Environment. Node Reboot is performed by CRS to maintain consistency in Cl... Read More
Configuration of AIX Fast Connect and SMBFS
Viewed 8248 times since Mon, Jun 18, 2018
Configuration of AIX Fast Connect and SMBFS Divya Vikas, Uma Chandolu, and Puneet MahajanPublished on December 18, 2007     The Common Internet File System (CIFS), also known as Server Message Block (SMB), is a standard remote file system ... Read More
AIX WIKIS developerworks
Viewed 2221 times since Sun, Jun 17, 2018
https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Power%20Systems/page/AIX Read More
Useful AIX commands
Viewed 9337 times since Sun, Jun 17, 2018
Useful AIX commands svmon svmon -P <pid> Further: use can user svmon command to monitor memory usage as follows; (A) #svmon -P -v -t 10 | more (will give top ten processes) (B) #svmon -U -v -t 10 | more ( will give top ten use... Read More
A tcpdump Tutorial and Primer with Examples
Viewed 4779 times since Sun, Jun 17, 2018
  A tcpdump Tutorial and Primer with Examples Created: January 4, 2004 | Updated: October 30, 2017   Why tcpdump? Basics Examples Basic Communication Specific Interface Raw Output View Find Traffic by IP Seeing Packet Contents with Hex Output ... Read More
NTLMSSP, SPN and AIX CIFS
Viewed 8026 times since Fri, Jun 15, 2018
NTLMSSP, SPN and AIX CIFS Today I had busy time trying to figure out why SMB/CIFS Windows Server 2008 share cannot be mounted in AIX. AIX # mount -v cifs -n WindowsMachine.re.somewh.ere/sysaccount5/PassWd -o wrkgrp=SOMEGROUP,uid=11345,gid=22345,fm... Read More
AIX: Script to get Total Disk Size
Viewed 3532 times since Tue, Jun 12, 2018
Single Server Total Disk Size (hdisk) 1 for i in `lspv |awk '{print $1}'`; do bootinfo -s $i; done |awk '{s+=$1} END {print s}' |while read x; do echo $x/1024|bc; done Total Disk Size (hdiskpower) 1 for i ... Read More
AIX: Script to check if all paths are consistent and available
Viewed 3028 times since Tue, Jun 12, 2018
Single Server 1 lspath | awk '{print $1,$NF}' |sort |uniq -c (OR) 1 2 3 4 5 for x in `lspath |awk '{print $2}' |sort -k1.6n |uniq` do status=`lspath -l $x` echo $status |sed 's/\ /,/g' done ... Read More
AIX: Script to create a file with commands to remove missing & failed paths
Viewed 3069 times since Tue, Jun 12, 2018
To create a file with commands to remove the missing paths 1 2 3 4 5 6 7 8 9 #!/bin/sh # rmpaths >xrmpaths echo "#!/bin/sh" >>xrmpaths disks=$(lspv | awk '{print $1}') for loop in $disks do lspath -l $loop -H -F "name:pare... Read More
VIO Server Howto
Viewed 9890 times since Mon, Jun 11, 2018
1. Run IOS commands as root According to IBM you should never work as root on VIO servers. However, if you login as user padmin and type oem_setup_env you get the root credentials (without even been asked for a password). By default the ioscli c... Read More
AIX: How to identify the program listening in the given port
Viewed 2306 times since Mon, Jun 11, 2018
METHOD I: # lsof –P –n –i :505 (for port 505) METHOD II: # netstat -Aan|grep 9404 f100060006952b98 tcp 0 0 *.9404 *.* LIST EN f100060006a90b98 tcp 0 0 *.19404 *.* LIST EN # rmsock f100060006952b98 tcpcb The socket 0x6952808 is being held by proccess ... Read More
AIX: How to set automatic logoff (only for terminals)
Viewed 2887 times since Mon, Jun 11, 2018
Edit the /etc/security/.profile file to include an automatic logoff value for all users, as in the following example: TMOUT=600 ; TIMEOUT=600 ; export readonly TMOUT TIMEOUT The number 600, in this example, is in seconds, which is equal to 10 minutes... Read More
AIX: How do you send an attachment via mail
Viewed 2698 times since Mon, Jun 11, 2018
Uuencode is the answer: uuencode [source-file] [filename].b64 mail -v -s “subject” [email-address] For example: # uuencode /etc/motd motd.b64 mail -v -s “Message of the day” email@hostname.comI use the .b64 extension which gets recognized by Winzip. ... Read More
Tips I Picked up at the Power Systems Technical University
Viewed 2654 times since Mon, Jun 11, 2018
Tips I Picked up at the Power Systems Technical University   November 2017 | by Jaqui Lynch   Print 350   References In October, I attended and spoke at the Power Systems Technical University in New Orleans. While I was there I was able... Read More
AIX: How to determine which application created the OS core file
Viewed 2325 times since Mon, Jun 11, 2018
# /usr/sbin/lquerypv -h /path/to/core 6b0 64 The output of this command is neat, clean and easy to read. Here is an example: # lquerypv -h core 6b0 64 000006B0 7FFFFFFF FFFFFFFF 7FFFFFFF FFFFFFFF ……………. 000006C0 00000000 000007D0 7FFFFFFF FFFFFFFF ……... Read More
AIX: How to manage network tuning parameters
Viewed 3587 times since Mon, Jun 11, 2018
The no command is used to configure network tuning parameters in IBM AIX. The no command sets or displays current or next boot values for network tuning parameters. This command can also make permanent changes or defer changes until the next reboot. ... Read More
IBM AIX commands you should not leave home without
Viewed 6971 times since Mon, Jun 11, 2018
As you know, AIX has a vast array of commands that enable you to do a multitude of tasks. Depending on what you need to accomplish, you use only a certain subset of these commands. These subsets differ from user to user and from need to need. However... Read More
AIX Health Check basic
Viewed 4211 times since Fri, Jun 8, 2018
AIX Health Check   To view overall performance. topas Option: -D Display all disks status -M Memory -P DIsplay all processes and sorted based on CPU utilization To view CPU utilization. sar -u 5 5 To view swap utilization. lsps -... Read More
To do a quick check on the number of path present (does not mean all are Enabled] using for loop
Viewed 3676 times since Fri, Jun 8, 2018
To do a quick check on the number of path present (does not mean all are Enabled] using for loop. ===================================================== for i in `/usr/sbin/lspath | grep scsi | awk  '{print $2}' | sort |uniq ` ;  do echo "$... Read More
How to check dual path in AIX
Viewed 13447 times since Fri, Jun 8, 2018
How to check dual path in AIX   How to verify if there is dual paths to SAN disks in AIX Operating System In this context we are using two important command which is lspath and dlmkmgr. lspath is the native AIX command which is included in the OS. d... Read More
AIX - How to shutdown or reboot
Viewed 4992 times since Fri, Jun 8, 2018
AIX - How to shutdown or reboot   To shutdown. shutdown             #shutdown after 60s shutdown now     #shutdown now shutdown -F        #shutdown forcefully To reboot. shutdown -r         #reboot - flush cache to disk shutdown -Fr       ... Read More
AIX - How to extend JFS filesystem
Viewed 18046 times since Fri, Jun 8, 2018
AIX - How to extend JFS filesystem   JFS on AIX machines can be extend online if needed.To do so follow the steps below.1. Identify the filesystem you want to extend.    Main thing we want to find out is on which logical volume it is using.==========... Read More
AIX - How to unlock and reset user’s account
Viewed 16260 times since Fri, Jun 8, 2018
AIX - How to unlock and reset user's account   Sometimes a user cannot remote login to an AIX machine might not due to just password expired issue. His/her account might have some other settings that prevent them from logging in. Below is a quic... Read More
AIX - How to get IP and MAC address of ethernet adapter in AIX
Viewed 24290 times since Fri, Jun 8, 2018
AIX - How to get IP and MAC address of ethernet adapter in AIX   Question : How to get MAC address of ethernet adapter in AIX? Answer : "netstat -v" command can be used to obtain MAC address of ethernet adapter in AIX. Search for "Hardware address" v... Read More
AIX - How to get network speed and statistic of ethernet adapter in AIX
Viewed 13209 times since Fri, Jun 8, 2018
AIX - How to get network speed and statistic of ethernet adapter in AIX   Question : How to get network speed of ethernet adapter in AIX. Answer : netstat command with option "v" can be used to get network speed of ethernet adapter in AIX. Look for m... Read More
AIX - How to monitor CPU usage
Viewed 26374 times since Fri, Jun 8, 2018
AIX - How to monitor CPU usage   In AX, topas can be used to monitor CPU usage of the system. Topas is similar to top in Linux though both are not the same. Question : How to monitor CPU usage in AIX? Answer : ps command can be used to report a snap... Read More
AIX - How to monitor memory usage
Viewed 4998 times since Fri, Jun 8, 2018
AIX - How to monitor memory usage   In AIX, ps command can be used to monitor status of processes. It will display information such as CPU usage, memory usage and etc of processes. To monitor memory usage of processes, RSS and %MEM column need to be ... Read More
AIX - How to get Memory infomation
Viewed 9457 times since Fri, Jun 8, 2018
AIX - How to get Memory infomation   Question : How to check memory size allocated to an AIX box if it is a lpar? Answer : lparstat command with option "i" can be used. Example : root@server # lparstat -i |grep -i memoryOnline Memory : 320 MBMaxim... Read More
AIX - How to get CPU infomation
Viewed 5270 times since Fri, Jun 8, 2018
AIX - How to get CPU infomation   Question : How to get CPU model, number of cores and speed on an AIX machine? Answer : Use prtconf to display system configuration information and look for information related to processor. Example : root@server #... Read More
Script HW/SW AIX
Viewed 8900 times since Mon, Jun 4, 2018
#### pwd;clear;SERVER=`hostname`sleep 2;>/tmp/${SERVER};echo "##########################" >> /tmp/${SERVER};echo "DATE: " >> /tmp/${SERVER};echo "---------------------------------------------------------------------" >> /tmp/${SE... Read More
Part 3, Monitoring your network packets and tuning the network
Viewed 5866 times since Mon, Jun 4, 2018
Optimizing AIX 7 network performance Part 3, Monitoring your network packets and tuning the network Martin Brown and Ken MilbergPublished on January 11, 2011 FacebookTwitterLinked InGoogle+E-mail this page 1 Content series: This ... Read More
Part 2, NFS monitoring and tuning
Viewed 6226 times since Mon, Jun 4, 2018
Optimizing AIX 7 network performance Part 2, NFS monitoring and tuning Ken Milberg and Martin BrownPublished on November 30, 2010 FacebookTwitterLinked InGoogle+E-mail this page 1 Content series: This content is part of the serie... Read More
Part 1, Network overview - Monitoring the hardware
Viewed 5236 times since Mon, Jun 4, 2018
Part 1, Network overview - Monitoring the hardware Martin Brown and Ken MilbergPublished on November 23, 2010 FacebookTwitterLinked InGoogle+E-mail this page 0 Content series: This content is part of the series:Optimizing AIX 7 n... Read More
LVM: Shrink & extend a filesystem/volume
Viewed 2025 times since Sun, Jun 3, 2018
LVM: Shrink & extend a filesystem/volume # Tested on AIX 5.3# Note: jfs2 allows to shrink the filesystem, but a jfs filesystem's size cannot be reduced# In this example we are reducing /local/opt in order to free some space to be# ass... Read More
AIX: Remove existing disk
Viewed 2486 times since Sun, Jun 3, 2018
AIX: Remove existing disk # Tested on AIX 6.1# Once disk is not used anymore (not assigned to a volume group or oracle ASM device, for# instance), we can remove it from system like this# Check beforelspv      hdisk0          00c6b1c54670e768   ... Read More
HMC: HMC and LPAR management commands
Viewed 6954 times since Sun, Jun 3, 2018
HMC: HMC and LPAR management commands # Tested on HMC v.6 / v.7# List of HMC commands, in case web based tool is not available, to# manage LPARs and HMC itself# HMC Management# -------------------------------------------------------------------... Read More
LVM: Display basic information about Physical Volumes, Volume Groups and Logical Volumes
Viewed 2787 times since Sun, Jun 3, 2018
LVM: Display basic information about Physical Volumes, Volume Groups and Logical Volumes # Display information about a Physical Volume within a Volume Group# -------------------------------------------------------------------------------------... Read More
LVM: Extend an existing Volume Group by adding a new disk
Viewed 5429 times since Sat, Jun 2, 2018
LVM: Extend an existing Volume Group by adding a new disk # Tested on AIX 6.1# First, verify the disk(s) to use on the VG with "lspv" or any other similar tool.# Ensure that disk is not being used/lspv   hdisk0          00f7136bab316a7a        ... Read More
AIX: Configuring a network interface
Viewed 3159 times since Sat, Jun 2, 2018
AIX: Configuring a network interface # Tested on AIX 6.1# Given following interface (no matter if it is already configured or not):ifconfig en3   en3: flags=1e080822,480<BROADCAST,NOTRAILERS,SIMPLEX,MULTICAST,GROUPRT,64BIT,CHECKSUM_OFFLOAD(A... Read More
AIX POWERHA/HACMP: Basic commands
Viewed 5182 times since Sat, Jun 2, 2018
POWERHA/HACMP: Basic commands # IBM PowerHA (formerly HACMP) is IBM's solution for high-availability clusters on the AIX# Unix and Linux for IBM System p platforms and stands for High Availability Cluster# Multiprocessing.# PowerHA c... Read More
Online Backups and Recovery in a Snap AIX
Viewed 4878 times since Wed, May 30, 2018
Online Backups and Recovery in a Snap   December 2012 | by David Tansley   Print 0     The ability to perform a JFS2 file system backup online means minimal downtime—and that’s a good thing in any system admin’s book. Using... Read More
Monitoring Events with AIX Audit
Viewed 3772 times since Wed, May 30, 2018
Monitoring Events with AIX Audit   August 2009 | by David Tansley   Print 1       The AIX* built-in audit subsystem allows system administrators to monitor and record security-related events on the system. This utility provides a good footin... Read More
Processes and Devices—It’s All About the Children
Viewed 2040 times since Wed, May 30, 2018
Processes and Devices—It’s All About the Children   April 2013 | by David Tansley   Print 3   Persistent Change Within the AIX (or Linux) world, if a process is spawned, a copy of the parent process is used and the child proc... Read More
How to Easily Generate AIX Systems Management Reports
Viewed 2847 times since Wed, May 30, 2018
How to Easily Generate AIX Systems Management Reports   August 2013 | by David Tansley   Print 0     Generating system management information service (MIS) reports is a common task for system administrators. These reports are generated as co... Read More
http://ibmsystemsmag.com/aix/administrator/backuprecovery/remote-sync/
Viewed 5254 times since Wed, May 30, 2018
Keeping Remote Files In Sync   July 2014 | by David Tansley   Remote Files In Sync Print 0     When you need to keep local files or directories in sync with a remote host, rsync utility ticks all the boxes. Rsync is the tool of choice when s... Read More
Convert to Scalable Volume Groups
Viewed 3575 times since Wed, May 30, 2018
Convert to Scalable Volume Groups   September 2014 | by David Tansley   Print 0     You may need to add extra disks to a volume group (VG) due to pure business data growth or because you require additional testing environments. You might fac... Read More
Many Choices for AIX File Integrity
Viewed 2583 times since Wed, May 30, 2018
Many Choices for AIX File Integrity   November 2014 | by David Tansley   Print 0     Recently, I was on a disaster recovery (DR) exercise that was going extremely well, until I had to restore a DB2 database. The restore failed due to a corru... Read More
Tunneling With SSH to Your Destination
Viewed 4029 times since Wed, May 30, 2018
Tunneling With SSH to Your Destination   January 2015 | by David Tansley   Print 1   Figure 1 Figure 2 With SSH, you can create a tunnel (port forwarding) to transfer data that will be encrypted. Using this tunnel, you can then connect t... Read More
Problems with NFS on an AIX Reboot? Then Go Single
Viewed 6926 times since Wed, May 30, 2018
Problems with NFS on an AIX Reboot? Then Go Single   March 2015 | by David Tansley   Print 0     A few weeks ago, I got called to review an issue where an AIX admin was cloning an AIX image onto a new LPAR. He said the reboot process was han... Read More
Customizing a NIM Client Restore With a Post-Install Script
Viewed 10802 times since Wed, May 30, 2018
Customizing a NIM Client Restore With a Post-Install Script   April 2015 | by David Tansley   Print 0   Figure 1 - nim_post_install_script After you’ve performed a NIM recovery—whether via a mksysb or a RTE (runtime environme... Read More
Restoring mksysb
Viewed 3351 times since Wed, May 30, 2018
Restoring mksysb   May 2015 | by David Tansley   Print 2     Every week, most AIX administrators take a weekly mksysb backup of rootvg. When it completes without problem, they generally shove it off to tape and forget about it. No need to wo... Read More
Migrating AIX User Environments
Viewed 2099 times since Wed, May 30, 2018
Migrating AIX User Environments   February 2016 | by David Tansley   Print 0     Recently we had a requirement to build a new AIX environment in a remote office. Due to the unreliable network pipe between our main operations office and the r... Read More
Using Shell Redirection: All About the Here-Doc
Viewed 10128 times since Wed, May 30, 2018
Using Shell Redirection: All About the Here-Doc   June 2016 | by David Tansley   Print 1     When gathering information from remote AIX hosts using SSH (Secure Shell), it will definitely make your life a lot easier to write the commands with... Read More
Control Your Logs AIX
Viewed 18756 times since Wed, May 30, 2018
Control Your Logs   August 2014 | by David Tansley   Print 0     Every AIX system generates log files, including those from third-party applications and admin scripts. If you don’t keep on top of log file maintenance, it can become a m... Read More
Removing Failed or Missing Paths
Viewed 2623 times since Wed, May 30, 2018
Removing Failed or Missing Paths   December 2014 | by David Tansley   Print 1     When changing storage mapping, you’ll find yourself with failed or missing disk paths on your AIX SAN. Failed paths are commonly due to a change that&rsq... Read More
IBM AIX multipath I/O (MPIO) resiliency and problem determination
Viewed 13156 times since Wed, May 30, 2018
IBM AIX multipath I/O (MPIO) resiliency and problem determination Using the new features of the IBM AIX MPIO lsmpio command for storage area network (SAN) fabric problem determination Gary DomrowPublished on February 19, 2018 FacebookTwitterL... Read More
https://www.ibm.com/developerworks/learn/aix/index.html
Viewed 11071 times since Wed, May 30, 2018
https://www.ibm.com/developerworks/learn/aix/index.html   Read More
HOWTO: Copy a filesystem on AIX
Viewed 2355 times since Mon, May 28, 2018
#!/usr/bin/ksh cmd=$0 old=$1 new=$2 if [ $# != 2 ] then    echo Syntax: ${cmd} "<src_directory>" "<new_directory>"    exit 1 fi # since the directory names might be entered as relative to current directory # change to each of the direct... Read More
Getting list users and groups in AIX
Viewed 3282 times since Mon, May 28, 2018
Run the following command to get the list of users and associated groups in AIX environment $ lsuser ALL Read More
How to setup an user in AIX
Viewed 2952 times since Mon, May 28, 2018
Follow the below steps to create a user in AIX and assign to a group. Step 1: Create a user mkuser user-name   Step 2: Create a group mkgroup group-name   Step 3: Create a home directory mkdir /home/users/user-name   Step 4: Provide permissions to ho... Read More
Finding password rules in AIX
Viewed 2515 times since Mon, May 28, 2018
In AIX 5.2, following file holds the password configuration /etc/security/user Read More
Unlock User ID in IBM AIX
Viewed 14895 times since Mon, May 28, 2018
AIX Version: 5.3.0.0 Note: Required root or sudo access to perform this function. To unlock an user that’s locked from several unsuccessful login attempts, follow the steps below. Replace <userid> with userid that needs to be unlocked in ... Read More
Backing up your VIOS configuration with viosbr.
Viewed 11390 times since Mon, May 28, 2018
After applying Fix Pack to my VIOS 2.1 server, I thought I’d try out the new viosbr command. $ ioslevel 1.2.10-FP-22 The man page for viosbr states that this command can be used to backup and restore the virtual I/O server configuration. ... Read More
IVM and VLAN Tagging
Viewed 10184 times since Mon, May 28, 2018
IVM and VLAN Tagging cggibbo |Nov 8 2011| Comments (9) | Visits (39247) 1 I was working with a customer recently on a Power Blade that was running the Integrated Virtualisation Manager (IVM). They’d installed a VIO partition onto the Blade and ... Read More
How to check VLAN ID number on AIX?
Viewed 12946 times since Mon, May 28, 2018
To check VLAN ID on AIX you can issue the command entstat filtering the result as the follow: # entstat -d en0 | grep 'Port VLAN ID' Port VLAN ID: 800 How to check VLAN-ID with command on LPAR for know information or something!! Serv01:ro... Read More
How to deal with performance monitoring in AIX ?
Viewed 7643 times since Fri, May 25, 2018
To display top 10 highly utilized files under /var FS: find /var –xdev –ls|sort +6rn|head   To list the top ten users of paging space in IBM AIX:  svmon -Pgt 10 To list the top ten users of realmem in IBM AIX:   svmon -Put 10 To see the memory us... Read More
Tuning AIX Network Performance
Viewed 3466 times since Tue, May 22, 2018
By default, the network tunables on an AIX system aren’t set optimally for anything above a 100 MB network. Given that most customers are running GB or 10 GB networks, the first step to improving network performance is to set some basic tunabl... Read More
Trouble Shooting AIX Networking
Viewed 2446 times since Tue, May 22, 2018
  TroubleShooting AIX   System Reporting wrong oslevel:   Network   1. Check the number of network interfaces and their status: # lsdev -CH | grep en ent0 available 10-68 3Com 3C905-TX-IBM fast Etherlink XL NIC ent1 defined 10-80 IBM PCI Ethernet Ada... Read More
AIX check the HBA status
Viewed 16148 times since Tue, May 22, 2018
The P5/6/7 hardware loaded with AIX. How to check the FC HBA status? This command lists all devices available in AIX system. #lsdev Among all devices, look for FC HBA adapter by using below command. #lsdev –Cc adapter |grep fcs* If the HBA’s l... Read More
Manually Editing /etc/filesystems Can Cause Issues
Viewed 5230 times since Tue, May 22, 2018
As an AIX administrator, editing files directly is part of the course. However, some system files require a bit of caution when editing. Let’s look at one example, the /etc/filesystems. When you create a file system, the underlying logical volu... Read More
Part 2, Detailed diagnosis and troubleshooting
Viewed 2708 times since Tue, May 22, 2018
Network problem determination: AIX tools for a system administrator Part 2, Detailed diagnosis and troubleshooting This article provides you with a set of commands available on IBM AIX®, many of which are also available on other flavors of UNIX®, tha... Read More
Part 1, The basics of network troubleshooting
Viewed 5078 times since Tue, May 22, 2018
Network problem determination: AIX tools for a system administrator Part 1, The basics of network troubleshooting As an IBM AIX® systems administrator, it's inevitable that at some point in your role you will encounter a problem that's link... Read More
10 AIX Commands to Add to Your Toolbox
Viewed 4193 times since Sat, May 19, 2018
Many UNIX commands work across the spectrum of UNIX flavors—but there are specific commands that are geared specifically for AIX. Learning these is essential to being a successful AIX systems administrator. This list will focus on commands that... Read More
Troubleshooting Starts With Understanding Your Physical Disks’ Attributes
Viewed 3578 times since Sat, May 19, 2018
Any disk—or for that matter physical volume (PV) or hdisk—you might have most likely has some form of data on it. Reviewing disk attributes can reveal much, and not just in terms of managed storage, such as the logical volume manager (LVM... Read More
Backup and Restore With AIX
Viewed 4219 times since Sat, May 19, 2018
While there are some strong third-party tools available to you for backup and restore purposes on the AIX OS, don't be afraid of the standard AIX toolset to archive your data. Most articles on backing up AIX partitions approach the subject tend ... Read More
How To Mirror Your Root Disk On AIX (a.k.a. rootvg)
Viewed 5082 times since Mon, May 21, 2018
Mirroring rootvg: The commands though this is a short process anyway..but anyway.. actual values used in my example, change those to suit your environment Sponsored Links lspv in my example, hdisk0 is rootvg, hdisk1 is not in use lsvg -l rootvg comp... Read More
How to mirror the rootvg in AIX?
Viewed 4759 times since Mon, May 21, 2018
How to mirror the rootvg in AIX? This procedure is to assume the rootvg having hdisk0 and we need to take a mirror to hdisk1.  Ground work:   lspv                                 --> find out the none disk on the server for the mirroring. b... Read More
Mirroring the rootvg Volume Group for AIX
Viewed 3802 times since Mon, May 21, 2018
Technote (FAQ) Question Mirroring the rootvg Volume Group for AIX Answer   This document specifies the supported method for mirroring the rootvg volume group to provide high availability access of the AIX operating system. There are four steps requ... Read More
Mirroring the rootvg Volume Group for AIX 4.1/4.2
Viewed 2933 times since Mon, May 21, 2018
The disks that constitute the boot drives for AIX, must be disks that are supported to boot on RS/6000 platforms. A machine and disk configuration may be queried to determine if that combination of machine and disk supports bootin... Read More
Replacing a failed disk (rootvg)
Viewed 2821 times since Mon, May 21, 2018
This post will describe the replacement of a failed rootvg disk. In short the procedure is the following: 1. unmirrorvg rootvg hdisk0 (savebase -v) 2. reducevg rootvg hdisk0 3. rmdev -Rdl hdisk0 4. diag (safely remove hot swap device/drive), physical... Read More
AIX rootvg Mirroring
Viewed 4373 times since Mon, May 21, 2018
Volume group Mirroring:- Volume group mirroring is the most essential which keeps the data into redundant way in-order to avoid possible data loss in case any hardware or disk failure. Moreover, mirroring technology has been called as RAID -1 level. ... Read More
How To Mirror VG and Root VG
Viewed 2948 times since Mon, May 21, 2018
How To Mirror VG and Root VG There are steps involved through which administrator can mirror a VG and RootVg. Steps tp mirror a VG: Step 1: Extend the VG. # extendvg <vgname> <pvname> Step 2: mirror the VG. # mirrorvg <vgname> <... Read More
System Admin Mirrorvg without locking the volume group
Viewed 2943 times since Mon, May 21, 2018
When you run the mirrorvg command, you will (by default) lock the volume group it is run against. This way, you have no way of knowing what the status is of the sync process that occurs after mirrorvg has run the mklvcopy commands for all the logical... Read More
LVM: Unmirror/Mirror "rootvg" Volume Group
Viewed 3215 times since Mon, May 21, 2018
Tested on AIX 5.3# UN-MIRRORING "rootvg"# ------------------------------------------------------------------------------------------# We are un-mirroring a "rootvg" VG distributed on "hdisk0" & "hdisk1" disks like this one# (we'll take "hdi... Read More
Rootvg Mirroring in AIX
Viewed 2521 times since Mon, May 21, 2018
Server is having 1 hard disk (hdisk0) in which OS is installed. The procedure will give step by step guide to attach a new hard disk to a running AIX machine and configure root mirroring. #lspv hdisk0 0005e8d264d0ec83 root... Read More