This is a quick and dirty method of setting up an LPP source and SPOT of AIX 5.3 TL10 SP2, without having to swap DVD's into the AIX host machine. What you basically need is the actual AIX 5.3 TL10 SP2 DVD's from IBM, a Windows host, and access to your NIM server. This process basically works for every AIX level, and has been tested with versions up to AIX 7.2.
If you have actual AIX DVD's that IBM sent to you, create ISO images of the DVD's through Windows, e.g. by using MagicISO. Or, go to Entitled Software Support and download the ISO images there.
SCP these ISO image files over to the AIX NIM server, e.g. by using WinSCP.
We need a way to access the data in the ISO images on the NIM server, and to extract the filesets from it (see IBM Wiki).
For AIX 5 systems and older:
Create a logical volume that is big enough to hold the data of one DVD. Check with "lsvg rootvg" if you have enough space in rootvg and what the PP size is. In our example it is 64 MB. Thus, to hold an ISO image of roughly 4.7 GB, we would need roughly 80 LPs of 64 MB.
# /usr/sbin/mklv -y testiso -t jfs rootvg 80Create filesystem on it:
# /usr/sbin/crfs -v jfs -d testiso -m /testiso -An -pro -tn -a frag=4096 -a nbpi=4096 -a ag=8Create a location where to store all of the AIX filesets on the server:
# mkdir /sw_depot/5300-10-02-0943-fullCopy the ISO image to the logical volume:
# /usr/bin/dd if=/tmp/aix53-tl10-sp2-dvd1.iso of=/dev/rtestiso bs=1mMount the testiso filesystem and copy the data:
# chfs -a vfs=cdrfs /testiso
# mount /testisoRepeat the above 5 steps for both DVD's. You'll end up with a folder of at least 4 GB.
# bffcreate -d /testiso -t /sw_depot/5300-10-02-0943-full all
# umount /testiso
Delete the iso logical volume:
# rmfs -r /testisoWhen you're using AIX 7 / AIX 6.1:
# rmlv testiso
Significant changes have been made in AIX 7 and AIX 6.1 that add new support for NIM. In particular there is now the capability to use the loopmount command to mount iso images into filesystems. As an example:
# loopmount -i aixv7-base.iso -m /aix -o "-V cdrfs -o ro"The above mounts the AIX 7 base iso as a filesystem called /aix.
So instead of going through the trouble of creating a logical volume, creating a file system, copying the ISO image to the logical volume, and mounting it (which is what you would have done on AIX 5 and before), you can do all of this with a single loopmount command.
Make sure to delete any left-over ISO images:
# rm -rf /tmp/aix53-tl10-sp2-dvd*isoDefine the LPP source (From the NIM A to Z redbook):
# mkdir /export/lpp_source/LPPaix53tl10sp2Check with:
# nim -o define -t lpp_source -a server=master -a location=/export/lpp_source/LPPaix53tl10sp2 -a source=/sw_depot/5300-10-02-0943-full LPPaix53tl10sp2
# lsnim -l LPPaix53tl10sp2Rebuild the .toc:
# nim -Fo check LPPaix53tl10sp2For newer AIX releases, e.g. AIX 7.1 and AIX 7.2, you may get a warning like:
If this happens, you can either do exactly what it says, copy the installp/ppc/bos.vendor.profile file from your source DVD ISO image into the installp/ppc directory of the LPP source. Or, you can remove the entire LPP source, then copy the installp/ppc/bos.vendor.profile form the DVD ISO image into the directory that contains the full AIX software set (in the example above: /sw_depot/5300-10-02-0943-full), and then re-create the LPP source. That should help to avoid the warning.Warning: 0042-354 c_mk_lpp_source: The lpp_source is missing a bos.vendor.profile which is needed for the simages attribute. To add a bos.vendor.profile to the lpp_source run the "update" operation with "-a recover=yes" and specify a "source" that contains a bos.vendor.profile such as the installation CD. If your master is not at level 5.2.0.0 or higher, then manually copy the bos.vendor.profile into the installp/ppc directory of the lpp_source.
If you ignore this warning, then you'll notice that the next step (create a SPOT from the LPP source) will fail.
Define a SPOT from the LPP source:
# nim -o define -t spot -a server=master -a location=/export/spot/SPOTaix53tl10sp2 -a source=LPPaix53tl10sp2 -a installp_flags=-aQg SPOTaix53tl10sp2Check the SPOT:
# nim -o check SPOTaix53tl10sp2
# nim -o lppchk -a show_progress=yes SPOTaix53tl10sp2