AIX - How to monitor CPU usage

AIX - How to monitor CPU usage

 
In AX, topas can be used to monitor CPU usage of the system. Topas is similar to top in Linux though both are not the same.

Question : How to monitor CPU usage in AIX?
Answer : ps command can be used to report a snapshot of the current processes in AIX. Use option aux and sort based on the column to get the top usage based on the parameter you need. If you need to get CPU then you will need to sort column 3.
Example :
[root@server ~]# while true;do echo `ps aux |head -1`;ps aux |sort -nrk 3| head -10;sleep 2;clear;done
Note : Above command will output top 10 processes with highest %CPU in an interval of 2 seconds. Press "Crtl C" to exit the while loop.


Question : How to monitor CPU usage in AIX?
Answer : Besides using method above, topas command can be used to monitor %CPU in AIX.
Example :
[root@server ~]# topas
[root@server ~]# topas -P <--- To display full screen of processes


Question : How to monitor CPU usage in AIX?
Answer : sar command can be used to monitor %CPU in AIX. Use sar with option "u" and specific the interval and numintervals needed.
Example :
[root@server ~]# sar -u 3 3
Note : Above command with execute sar -u in an interval of 3 seconds for 3 times.
4 (1)
Article Rating (1 Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Top 4 Reasons for Node Reboot or Node Eviction in Real Application Cluster (RAC) Environment
Viewed 72064 times since Thu, Jun 21, 2018
Topics: AIX, System Admin↑ Export and import PuTTY sessions
Viewed 2430 times since Fri, Apr 19, 2019
Useful AIX commands
Viewed 8827 times since Sun, Jun 17, 2018
SSH Essentials: Working with SSH Servers, Clients, and Keys
Viewed 3826 times since Wed, Jun 27, 2018
AIX - How to get network speed and statistic of ethernet adapter in AIX
Viewed 11177 times since Fri, Jun 8, 2018
n a perfect world....rootvg would always reside on hdisk0
Viewed 1941 times since Thu, Jun 6, 2019
0516-787 extendlv: Maximum allocation for logical volume error
Viewed 7901 times since Tue, Mar 12, 2019
How To Mirror Your Root Disk On AIX (a.k.a. rootvg)
Viewed 4507 times since Mon, May 21, 2018
Checking HBA status on AIX
Viewed 16624 times since Fri, Oct 5, 2018
Configuring an AIX client with multiple Kerberos realms
Viewed 8372 times since Mon, Jun 25, 2018