Create volume groups on AIX - Normal Big Scalable

You can create three types of volume groups on AIX:

  • Normal
  • Big
  • Scalable
VG type      Max-PVs      Max-LVs         Max-PPs per VG         Max-PP per size
Normal          32           256              32,512                    1 GB
Big            128           512             130,048                    1 GB
Scalable      1024          4096           2,097,152                  128 GB

First, identify free disk you want to use. In our case is hdisk2.

[root@aix:/] lspv
hdisk0 000fd1bbd4229068 rootvg active
hdisk2 000fd1bb7390f5fb None

Create a NORMAL type volume group:

[root@aix:/] mkvg -y normalvg hdisk2
normalvg

Let’s verify:

[root@aix:/] lsvg normalvg
VOLUME GROUP:       normalvg                 VG IDENTIFIER:  000fd1bb0000d4000000015982f0724b
VG STATE:           active                   PP SIZE:        4 megabyte(s)
VG PERMISSION:      read/write               TOTAL PPs:      511 (2044 megabytes)
MAX LVs:            256                      FREE PPs:       511 (2044 megabytes)
LVs:                0                        USED PPs:       0 (0 megabytes)
OPEN LVs:           0                        QUORUM:         2 (Enabled)
TOTAL PVs:          1                        VG DESCRIPTORS: 2
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:         1                        AUTO ON:        yes
MAX PPs per VG:     32512
MAX PPs per PV:     1016                     MAX PVs:        32
LTG size (Dynamic): 512 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                       BB POLICY:      relocatable
PV RESTRICTION:     none                     INFINITE RETRY: no
DISK BLOCK SIZE:    512                      CRITICAL VG:    no	

Create a BIG type volume group:

[root@aix:/] mkvg  -B -y bigvg hdisk2
bigvg

Let’s verify:

[root@aix:/] lsvg bigvg
VOLUME GROUP:       bigvg                 VG IDENTIFIER:  000fd1bb0000d4000000015982f0dd62
VG STATE:           active                PP SIZE:        4 megabyte(s)
VG PERMISSION:      read/write            TOTAL PPs:      509 (2036 megabytes)
MAX LVs:            512                   FREE PPs:       509 (2036 megabytes)
LVs:                0                     USED PPs:       0 (0 megabytes)
OPEN LVs:           0                     QUORUM:         2 (Enabled)
TOTAL PVs:          1                     VG DESCRIPTORS: 2
STALE PVs:          0                     STALE PPs:      0
ACTIVE PVs:         1                     AUTO ON:        yes
MAX PPs per VG:     130048
MAX PPs per PV:     1016                  MAX PVs:        128
LTG size (Dynamic): 512 kilobyte(s)       AUTO SYNC:      no
HOT SPARE:          no                    BB POLICY:      relocatable
PV RESTRICTION:     none                  INFINITE RETRY: no
DISK BLOCK SIZE:    512                   CRITICAL VG:    no

Create a SCALABLE type volume group:

[root@aix:/] mkvg -y scalablevg -S -P 1024 -v 4096 hdisk2
scalablevg

Let’s verify:

[root@aix:/] lsvg scalablevg
VOLUME GROUP:       scalablevg               VG IDENTIFIER:  000fd1bb0000d4000000015982efddcd
VG STATE:           active                   PP SIZE:        4 megabyte(s)
VG PERMISSION:      read/write               TOTAL PPs:      494 (1976 megabytes)
MAX LVs:            256                      FREE PPs:       494 (1976 megabytes)
LVs:                0                        USED PPs:       0 (0 megabytes)
OPEN LVs:           0                        QUORUM:         2 (Enabled)
TOTAL PVs:          1                        VG DESCRIPTORS: 2
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:         1                        AUTO ON:        yes
MAX PPs per VG:     32768                    MAX PVs:        1024
LTG size (Dynamic): 512 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                       BB POLICY:      relocatable
MIRROR POOL STRICT: off
PV RESTRICTION:     none                     INFINITE RETRY: no
DISK BLOCK SIZE:    512                      CRITICAL VG:    no

You can also convert a VG from BIG or (NORMAL) to SCALABLE using ‘chvg’ command

NOTE: VG must be varyoff before convertion!

[root@nodetest:/] chvg -G newvg
0516-1224 chvg: WARNING, once this operation is completed, volume group newvg
cannot be imported into AIX 5.2 or lower versions. Continue (y/n)  y
0516-1712 chvg: Volume group newvg changed. newvg can include up to 1024 physical volumes with 2097152 total physical partitions in the volume group.

[root@nodetest:/] varyonvg newvg
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
How to determine why your AIX oslevel is downlevel (and a script to help!)
Viewed 3608 times since Fri, Jul 13, 2018
How to build a NIM Server on AIX 6.1 from the Scratch :: Part 1
Viewed 4550 times since Thu, Nov 29, 2018
AIX, System Admin↑ The chrctcp command
Viewed 2842 times since Fri, Apr 19, 2019
AIX 0516-404 allocp: This system cannot fulfill the allocation
Viewed 3068 times since Thu, Sep 20, 2018
Using the AIX splitvg command
Viewed 3948 times since Mon, Jun 3, 2019
Kerberos, Active Directory and AIX
Viewed 6032 times since Mon, Jun 25, 2018
bootlist multiple boot logical volume found
Viewed 2524 times since Tue, Apr 16, 2019
IP configuration in AIX
Viewed 2449 times since Tue, Jul 17, 2018
Install and configure yum on AIX
Viewed 4278 times since Thu, Feb 21, 2019
Troubleshooting Starts With Understanding Your Physical Disks’ Attributes
Viewed 3456 times since Sat, May 19, 2018