AIX Commands Related to Boot and Init Process
AIX Commands Related to Boot and Init Process
1) To find the run-level in which system is working
a) #who -r
b) cat /etc/.init.state
2) To change the runlevel from one to other
#telinit M or shutdown -m –> Go to maintenance mode (single user mode)
#telinit 2
3) Shows the bootlist in normal mode & Service mode
#bootlist -m normal -o
#bootlist -m service -o
4) Sets the bootlist in the normal mode and service mode
#bootlist -m normal hdisk1 hdisk2
#bootlist -m service cd0 hdisk1
5) To show the boot disks location code
#bootlist -m normal -ov
‘ibm,max-boot-devices’ = 0x5
NVRAM variable: (boot-device=/pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:2)
Path name: (/pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:4) <–this pathname shows which blv is used
match_specific_info: ut=disk/scsi/scsd
hdisk0 blv=bos_hd5
8) To shows state of boot record
#ipl_varyon -i
PVNAME BOOT DEVICE PVID VOLUME GROUP ID hdisk0 YES 00183dfeba601b30000000000000000 000183df00004c00 hdisk1 NO 000183df1bc488990000000000000000 000183df00004c00
Where, hdisk0 is the boot device
9) Creates new boot record
#bosboot -ad hdisk3
10)To clears the boot record
#chpv -c hdisk3
11) To obtain the boot device
#lslv -m hd5
12)To see the system architecture ( RS6K,P series)
#bootinfo -p
13) To see the bit addressing (32 bit or 64 bit)
#bootinfo -y
14) To check the RAM size
#bootinfo -r
15) To check the bootable disk
#bootinfo -b
16) To check the size of the hard disk
#bootinfo -s hdisk3
17) Specifies the type of boot
#bootinfo -t
18) To shutdown the server
#shutdown
#shutdown -F (Fast shutdown)
#halt (ungraceful shutdown)
19) Shutdown with grace period
#shutdown +3 “System is going to shutdown”
20) To reboot the server
#shutdown -Fr
#reboot or #fastreboot ( Can be used if no users logged into the system)
Normally reboot kill the processes only, leaves the process and
communications running
21) To maintenance mode
#shutdown -m
22) Info about boot
#who -b
#last reboot
#uptime
23) how to find where is the bootimage?
#bootinfo -v