IP configuration in AIX

IP configuration in AIX

Here are some TCP/IP related commands, might be usefull.
Generally by using ifconfig and route commands your settings will not be preserved after the reboot, because the settings will not be stored in the ODM.
So to make the settings persistent across reboots use mktcpip or chdev for IP configuration and for the routing table smit route, /etc/rc.net or chdev

List routes stored in ODM

# odmget -q "attribute=route" CuAt

View curent routing table

# netstat -rn

Delete default route (persistent)

# chdev -l inet0 -a delroute=net,-hopcount,0,,0,192.168.2.2

Define default route (persistent)

# chdev -l inet0 -a route=net,-hopcount,0,,0,192.168.2.1

Lookup route information

# route get 

To permanently assign a IP to the en1 interface:

# chdev -l en1 -a netaddr=192.168.2.98 -a netmask=255.255.255.0

The following command sets the IP configuration on the specified adpter, adds an entry into /etc/hosts, and adds a static route to the routing table.

                  | Hostname           
# mktcpip -i en2 -h power1 -g 192.168.2.2 -a 192.168.4.6 -m 255.255.255.0
           |                |              |              |
           Interface        Gateway        Address        Netmask

View inet0 configuration

# lsattr -El inet0

To create a persistent IP alias:

         Interface name
         | 
# chdev -l en0 -a alias4=192.168.4.77,255.255.255.0
en0 changed     |
                Attribute

To permanently remove an IP alias

         Interface name     IP and netmask as shwon in `lsattr -El en0`
         |                  | 
# chdev -l en0 -a delalias4=192.168.2.77,255.255.255.0
en0 changed     |
                Attribute

Media link speed for the en0 interface

# entstat -d en0 | grep "Media Speed"

Show all listening ports

netstat -anf inet | grep LISTEN

Show domain name server settings

# namerslv -s
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
AIX 6/7 Script to create a file with commands to remove missing and failed paths
Viewed 3753 times since Tue, Jun 14, 2022
Technology level update on AIX using smit_update and alt_disk_install method
Viewed 5891 times since Sun, Jun 30, 2019
AIX lspath Missing path
Viewed 10062 times since Fri, Oct 5, 2018
AIX, System Admin↑ The chrctcp command
Viewed 3146 times since Fri, Apr 19, 2019
Reconfigure RSCT ID to fix DLPAR issues on cloned AIX systems
Viewed 14030 times since Thu, Feb 21, 2019
Migrating from SDDPCM to AIXPCM (the easy way)
Viewed 2690 times since Mon, Jun 3, 2019
What is OS Watcher Utility and How to use it for Database Troubleshooting ?
Viewed 30206 times since Thu, Jun 21, 2018
AIX ODM for MPIO User Guide 09
Viewed 4055 times since Mon, Dec 31, 2018
Monitor logfiles and command output on AIX using multitail.
Viewed 2404 times since Thu, Feb 21, 2019
AIX NTP Client configuration
Viewed 12191 times since Tue, Jul 17, 2018