vfcpmap on VIO Server
Article Number: 605 | Rating: Unrated | Last Updated: Tue, Jun 4, 2019 1:46 PM
vfcpmap on VIO Server
vfcmap command maps and unmaps the virtual fibre channel adapter to the physical fibre channel port.
To Map the virtual fibre channel ,vfchost1 to the physical fibre channel port, fcs0
# vfcmap -vadapter vfchost0 -fcp fcs0
To unmap the virtual fibre channel, vfchost3 to the physical fibre channel port, fcs3
# vfcmap -vadapter vfchost3 -fcp
USB Drive Mount Procedure on AIX Server.
1.Connect the USB drive to the server and discover it in OS.
#cfgmgr
2. Find the newly detected USB device name:
#lsdev -C|grep usbms
Ex: assume the newly detected device name is usbms0
3. create the filesystem on USB drive:
#mkfs -V jfs2 -o ea=v2 /dev/usbms0
4. Create the mount point and mount the drive on it.
#mkdir /usbdrive
#mount -o log=NULL /dev/usbms0 /usbdrive
5. Check is drive mounted or not:
# df -g|grep usbdrive
6. copy the data to it
#cp /work/test.txt /usbdrive
#ls -l /usbdrive -- should show test.txt file in it.
#cfgmgr
2. Find the newly detected USB device name:
#lsdev -C|grep usbms
Ex: assume the newly detected device name is usbms0
3. create the filesystem on USB drive:
#mkfs -V jfs2 -o ea=v2 /dev/usbms0
4. Create the mount point and mount the drive on it.
#mkdir /usbdrive
#mount -o log=NULL /dev/usbms0 /usbdrive
5. Check is drive mounted or not:
# df -g|grep usbdrive
6. copy the data to it
#cp /work/test.txt /usbdrive
#ls -l /usbdrive -- should show test.txt file in it.
Recovery From A Deleted /dev Directory in AIX
Note that AIX recreates most of /dev on boot, but we need a certain amount.
========================================
Problem(Abstract): The /dev directory was accidentally deleted.
========================================
Symptom: System wont boot
========================================
Environment: AIX 5.3 (and others)
========================================
Resolving the problem
Boot system into maintenance mode.
Access a root volume group before mounting filesystems
mount /dev/hd4 /mnt
mount /dev/hd2 /mnt/usr
mknod /mnt/dev/hd1 b 10 8
mknod /mnt/dev/hd2 b 10 5
mknod /mnt/dev/hd3 b 10 7
mknod /mnt/dev/hd4 b 10 4
mknod /mnt/dev/hd5 b 10 1
mknod /mnt/dev/hd6 b 10 2
mknod /mnt/dev/hd8 b 10 3
mknod /mnt/dev/hd9var b 10 6
umount /mnt/usr
umount /mnt
shutdown -Fr
How to view system Serial Number in AIX
# lsconf | grep -i "Machine Serial"
# prtconf | grep -i "Machine Serial"
# lsattr -El sys0 -a systemid
AIX Logs:
List of AIX Logs
/var/adm/ras/lvmcfg.log # lvm log file shows what lvm commands were used (alog -ot lvmcfg)
alog -L # List the defined log types
alog -o -t boot # View the boot log
alog -o -t console # View the console log
Viewing the contents of a disk without varying on the VG in AIX
To view a disk without varying it on:
# lqueryvg -p hdisk0 -L
00c9b6fb00004c000000013a8c97f698.1 backup_lv 1
00c9b6fb00004c000000013a8c97f698.2 loglv01 1
00c9b6fb00004c000000013a8c97f698.3 fslv19 1
00c9b6fb00004c000000013a8c97f698.4 was70bkp 1
00c9b6fb00004c000000013a8c97f698.5 paging00 1
00c9b6fb00004c000000013a8c97f698.6 fixes_lv 1