Configure log file for cron daemon on AIX

Cron daemon log in by default on /var/adm/cron/log, but I wanted to put it with all other logs of the system.
All system logs (syslog, mksysb, ftp, http, and so on, are on /var/syslog filesystem, I decided to put cron logs in the same place. Here’s what I did.

Add this lines to the end of file /etc/cronlog.conf

logfile=/var/syslog/cron.log
size=2m
rotate=4
archive=/var/syslog
compress

As cron is started from inittab it will respawn when you kill the PID.

[root@aix:/] cat /etc/inittab|grep cron
cron:23456789:respawn:/usr/sbin/cron

So, just kill cron’s PID (10748102 in this case)

[root@aix:/var/adm/cron] ps -ef|grep cron
    root 10748102        1   0 18:35:42      -  0:00 /usr/sbin/cron

Note also that cron log wil be rotate and compress. See:

[root@bibmnim:/var/adm/cron] ls -ltr /var/syslog/
total 18752
drwxr-xr-x    2 root     system          256 Mar 01 2011  lost+found
-rw-rw-r--    1 root     cron         164711 Apr 21 23:58 cron.log.0.Z
-rw-rw-r--    1 root     cron         165926 Apr 27 12:29 cron.log.1.Z
-rw-rw-r--    1 root     cron         165527 May 03 01:01 cron.log.2.Z
-rw-rw-r--    1 root     cron         164224 May 08 13:45 cron.log.3.Z
-rw-rw-r--    1 root     cron           1493 May 13 18:41 cron.log

That’s it!

Just thanks if the post was helpful

5 (1)
Article Rating (1 Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Install and configure yum on AIX
Viewed 4073 times since Thu, Feb 21, 2019
How to determine why your AIX oslevel is downlevel (and a script to help!)
Viewed 3409 times since Fri, Jul 13, 2018
AIX, Storage, System Admin Allocating shared storage to VIOS clients
Viewed 1883 times since Fri, Apr 19, 2019
AIX, Monitoring, Networking, Red Hat, Security, System Admin↑ Determining type of system remotely
Viewed 1840 times since Fri, Apr 19, 2019
7 Tips – Tuning Command Line History in Bash
Viewed 4424 times since Fri, Jul 5, 2019
How To Mirror Your Root Disk On AIX (a.k.a. rootvg)
Viewed 4507 times since Mon, May 21, 2018
AIX HOW TO CLONE A ROOTVG USING ALTERNATE DISK INSTALLATION ALTER_DISK_COPY
Viewed 14725 times since Sun, Jun 30, 2019
How to check dual path in AIX
Viewed 12499 times since Fri, Jun 8, 2018
AIX TCP connection status
Viewed 15452 times since Mon, Jul 29, 2019
Awesome Command to show top 15 processes using memory on AIX
Viewed 23239 times since Thu, Nov 29, 2018