0516-404 allocp: This system cannot fulfill the allocation request. [AIX]
Article Number: 361 | Rating: 5/5 from 3 votes | Last Updated: Thu, Sep 20, 2018 1:53 PM
0516-404 allocp: This system cannot fulfill the allocation request. [AIX]
Hello all, today I’m going to talk about an error that I have faced today during I was trying to increase a filesystem/Logical Volume :
hostname # chfs -a size=+1G /filesystem/path 0516-404 allocp: This system cannot fulfill the allocation request. There are not enough free partitions or not enough physical volumes to keep strictness and satisfy allocation requests. The command should be retried with different allocation characteristics.
The reason of this error was the UpperBound that were 1 and the space which I was increasing was available in a different disk that before, so My data was just spread in 1 disk :
hostname # lslv lvname
LOGICAL VOLUME:
lvname VOLUME GROUP: vgfeliz
LV IDENTIFIER: XXXXXXXX PERMISSION: read/write
VG STATE: active/complete LV STATE: opened/syncd
TYPE: jfs2 WRITE VERIFY: off
MAX LPs: 512 PP SIZE: 128 megabyte(s)
COPIES: 1 SCHED POLICY: parallel
LPs: 16 PPs: 16
STALE PPs: 0 BB POLICY: relocatable
INTER-POLICY: minimum RELOCATABLE: yes
INTRA-POLICY: middle UPPER BOUND: 1
MOUNT POINT: /filesystem/path LABEL: /filesystem/path
hostname # lslv -l lvname lvname:/filesystem/path PV COPIES IN BAND DISTRIBUTION hdisk22 016:000:000 6% 002:001:002:002:009
In this situation, you cannot increase the LV if the targeted size will spread on more disks than the “UPPER BOUND” value. So you have to change it with the chlv command:
hostname # chlv -u 32
lvname
hostname # lslv lvname
LOGICAL VOLUME:
lvname VOLUME GROUP: vgfeliz
LV IDENTIFIER: XXXXXXXX PERMISSION: read/write
VG STATE: active/complete LV STATE: opened/syncd
TYPE: jfs2 WRITE VERIFY: off
MAX LPs: 512 PP SIZE: 128 megabyte(s)
COPIES: 1 SCHED POLICY: parallel
LPs: 16 PPs: 16
STALE PPs: 0 BB POLICY: relocatable
INTER-POLICY: minimum RELOCATABLE: yes
INTRA-POLICY: middle UPPER BOUND: 32
MOUNT POINT: /filesystem/path LABEL: /filesystem/path
I selected 32 disks because I pretend to have more disks in the future.