AIX: Script to get Total Disk Size

Single Server

Total Disk Size (hdisk)

1
for i in `lspv |awk '{print $1}'`; do bootinfo -s $i; done |awk '{s+=$1} END {print s}' |while read x; do echo $x/1024|bc; done

Total Disk Size (hdiskpower)

1
for i in `lspv |grep hdiskpower |awk '{print $1}'`; do bootinfo -s $i; done |awk '{s+=$1} END {print s}' |while read x; do echo $x/1024|bc; done
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Script to reset NIM state and deallocate resources
Viewed 2089 times since Thu, Feb 21, 2019
Changing Ethernet Media Speed for AIX
Viewed 3018 times since Tue, Apr 16, 2019
IP configuration in AIX
Viewed 2384 times since Tue, Jul 17, 2018
Technology level update on AIX using smit_update and alt_disk_install method
Viewed 5301 times since Sun, Jun 30, 2019
Part 2, Detailed diagnosis and troubleshooting
Viewed 2573 times since Tue, May 22, 2018
AIX: Script to create a file with commands to remove missing & failed paths
Viewed 2865 times since Tue, Jun 12, 2018
Create bootable DVD iso image from a mksysb backup
Viewed 3972 times since Tue, Jul 17, 2018
Processes and Devices—It’s All About the Children
Viewed 1893 times since Wed, May 30, 2018
AIX Net How to check VLAN ID number on AIX?
Viewed 14648 times since Thu, Nov 29, 2018
Epoch & Unix Timestamp Conversion Tools
Viewed 45369 times since Fri, Jun 22, 2018