AIX Creating EtherChannel Devices from Command Line

I needed to create some EtherChannel devices on several AIX LPARs, and did not want to go through the smit panels every time.

I was testing network performance and wanted to add these to a script, so I could test standalone adapter configurations vs EtherChannel configurations, and leave my scripts running over night.

Here are the steps to create an EtherChannel device on AIX.

 

Create the eth device.  My primary Ethernet adapter is ent1 and the backup adapter is ent3.  This EtherChannel device will fail-over to the backup adapter and fail-back to the primary automatically.  The netaddr supplied is a reliable network device to ping to confirm which adapters are up or down, so I used the default gateway.

mkdev -c adapter -s pseudo -t ibm_ech -a adapter_names='ent1' -a backup_adapter='ent3' -a netaddr='192.168.2.1' -a num_retries='2' -a retry_time='1'

 

Create the et and en devices.

/usr/lib/methods/defif

 

Now add the IP address to the EtherChannel device.

chdev -l en4 -a netaddr=192.168.2.100 -a netmask=255.255.255.0 -a state=up

 

To clean up and delete the EtherChannel, just rmdev the ent, en and et devices, then configure one of the standalone adapters with the servers IP address as needed.

 

0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Create bootable DVD iso image from a mksysb backup
Viewed 4928 times since Tue, Jul 17, 2018
Monitor logfiles and command output on AIX using multitail.
Viewed 2552 times since Thu, Feb 21, 2019
AIX TCP connection status
Viewed 17284 times since Mon, Jul 29, 2019
Install and configure yum on AIX
Viewed 4865 times since Thu, Feb 21, 2019
Topics: PowerHA / HACMP, Storage Adding a new volume group to an active PowerHA resource group
Viewed 2829 times since Mon, Jun 3, 2019
How to Analyze or Read OS Watcher Output in three easy steps -- With Example ?
Viewed 42115 times since Thu, Jun 21, 2018
AIX, Networking↑ Adding and deleting a static network route using the command line
Viewed 2914 times since Fri, Apr 19, 2019
Many Choices for AIX File Integrity
Viewed 2869 times since Wed, May 30, 2018
Configuration of AIX Fast Connect and SMBFS
Viewed 8781 times since Mon, Jun 18, 2018
Script to make mksysb backup from NIM to LPAR
Viewed 3818 times since Thu, Feb 21, 2019