LVM: Extend an existing Volume Group by adding a new disk

LVM: Extend an existing Volume Group by adding a new disk

# Tested on AIX 6.1

# First, verify the disk(s) to use on the VG with "lspv" or any other similar tool.
# Ensure that disk is not being used/

lspv
   hdisk0          00f7136bab316a7a                    rootvg          active
   hdisk1          00f7136b82d34d5a                    datavg          active
   hdisk2          none                                None
   hdisk3          none                                None
   hdisk4          none                                None
   hdisk5          none                                None
   hdisk6          none                                None
   hdisk7          none                                None
   hdisk8          none                                None    <----
   hdisk9          none                                None


DISK=hdisk8
VG=datavg

# Check before

lsvg $VG
   VOLUME GROUP:       datavg                   VG IDENTIFIER:  00f7136b00004c000000013782d34d78
   VG STATE:           active                   PP SIZE:        128 megabyte(s)
   VG PERMISSION:      read/write               TOTAL PPs:      103 (13184 megabytes)   <----
   MAX LVs:            512                      FREE PPs:       0 (0 megabytes)
   LVs:                2                        USED PPs:       103 (13184 megabytes)
   OPEN LVs:           2                        QUORUM:         2 (Enabled)
   TOTAL PVs:          1                        VG DESCRIPTORS: 2
   STALE PVs:          0                        STALE PPs:      0
   ACTIVE PVs:         1                        AUTO ON:        yes
   MAX PPs per VG:     130048
   MAX PPs per PV:     1016                     MAX PVs:        128
   LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
   HOT SPARE:          no                       BB POLICY:      relocatable
   PV RESTRICTION:     none                     INFINITE RETRY: no



# Add disk to VG

extendvg $VG $DISK
   0516-1254 extendvg: Changing the PVID in the ODM.


# Check after

lspv
   hdisk0          00f7136bab316a7a                    rootvg          active
   hdisk1          00f7136b82d34d5a                    datavg          active
   hdisk2          none                                None
   hdisk3          none                                None
   hdisk4          none                                None
   hdisk5          none                                None
   hdisk6          none                                None
   hdisk7          none                                None
   hdisk8          00c6b1c5fa811973                    datavg          active   <----
   hdisk9          none                                None


lsvg $VG
   VOLUME GROUP:       datavg                   VG IDENTIFIER:  00f7136b00004c000000013782d34d78
   VG STATE:           active                   PP SIZE:        128 megabyte(s)
   VG PERMISSION:      read/write               TOTAL PPs:      206 (26368 megabytes)   <----
   MAX LVs:            512                      FREE PPs:       103 (13184 megabytes)
   LVs:                2                        USED PPs:       103 (13184 megabytes)
   OPEN LVs:           2                        QUORUM:         2 (Enabled)
   TOTAL PVs:          2                        VG DESCRIPTORS: 3
   STALE PVs:          0                        STALE PPs:      0
   ACTIVE PVs:         2                        AUTO ON:        yes
   MAX PPs per VG:     130048
   MAX PPs per PV:     1016                     MAX PVs:        128
   LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
   HOT SPARE:          no                       BB POLICY:      relocatable
   PV RESTRICTION:     none                     INFINITE RETRY: no
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
How to know witch process is running in a particular port on AIX using KDB
Viewed 12625 times since Thu, Nov 29, 2018
Ethernet tunning for VIOS and AIX for 10 Gib/sec environtement.
Viewed 10383 times since Thu, Feb 21, 2019
AIX FC Performance improvements for IBM AIX FC and FCoE device driver stacks
Viewed 5714 times since Fri, Jan 31, 2020
How to check dual path in AIX
Viewed 13819 times since Fri, Jun 8, 2018
AIX, Monitoring, System Admin↑ NMON recordings
Viewed 2968 times since Fri, Apr 19, 2019
Getting bosboot errors, don’t reboot just yet
Viewed 2831 times since Tue, Apr 16, 2019
Script to show Total, Free and Used Memory on AIX
Viewed 3363 times since Thu, Nov 29, 2018
Problem on resizing volume group on AIX 0516-1714, 0516-792, 0516-787, and 0516-404
Viewed 2591 times since Fri, Jul 6, 2018
AIX, Security, System Admin Difference between sticky bit and SUID/GUID
Viewed 8938 times since Fri, Apr 19, 2019
What is OS Watcher Utility and How to use it for Database Troubleshooting ?
Viewed 29936 times since Thu, Jun 21, 2018