AIX 6/7 Script to create a file with commands to remove missing and failed paths

To create a file with commands to remove the missing paths

1
2
3
4
5
6
7
8
9
#!/bin/sh
# rmpaths
>xrmpaths
echo "#!/bin/sh" >>xrmpaths
disks=$(lspv | awk '{print $1}')
for loop in $disks
do
lspath -l $loop -H -F "name:parent:connection:status" |grep Missing| awk -F: '{print "rmpath -dl",$1,"-p", $2, "-w", $3}'>>xrmpaths
done

 

To create a file with commands to remove the failed paths

1
2
3
4
5
6
7
8
9
#!/bin/sh
# rmpaths
>xrmpaths
echo "#!/bin/sh" >>xrmpaths
disks=$(lspv | awk '{print $1}')
for loop in $disks
do
lspath -l $loop -H -F "name:parent:connection:status" |grep Failed| awk -F: '{print "rmpath -dl",$1,"-p", $2, "-w", $3}'>>xrmpaths
done
5 (1)
Article Rating (1 Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
0516-404 allocp: This system cannot fulfill the allocation request. [AIX]
Viewed 4764 times since Thu, Sep 20, 2018
Monitoring Events with AIX Audit
Viewed 3622 times since Wed, May 30, 2018
LVM: Shrink & extend a filesystem/volume
Viewed 1927 times since Sun, Jun 3, 2018
AIX alt_disk_copy
Viewed 9506 times since Sun, Jun 30, 2019
AIX HA / HACMP, System Admin↑ Mountguard
Viewed 6150 times since Mon, Jun 3, 2019
AIX Replacing a failed disk (rootvg)
Viewed 8136 times since Tue, Jul 17, 2018
AIX PDF ALL
Viewed 6250 times since Mon, Jul 16, 2018
Many Choices for AIX File Integrity
Viewed 2474 times since Wed, May 30, 2018
AIX, Security, System Admin↑ Fix user accounts
Viewed 4440 times since Fri, Apr 19, 2019
A Unix Utility You Should Know About: lsof
Viewed 1748 times since Tue, Apr 16, 2019