How to deal with performance monitoring in AIX ?

To display top 10 highly utilized files under /var FSfind /var –xdev –ls|sort +6rn|head

 

To list the top ten users of paging space in IBM AIX:  svmon -Pgt 10

To list the top ten users of realmem in IBM AIX:   svmon -Put 10

To see the memory usage of that process:  svmon –p pid       

 

To display top 10 CPU-consuming processes: ps aux | head -1; ps aux | sort -rn +2 | head

 

To display top 10 memory-consuming processes: ps -ealf | head -1 ; ps -ealf | sort -rn +9 | head

 

To display processes in order of being penalized: ps -eakl | head -1 ; ps -eakl | sort -rn +5

 

To display processes in order of priority: ps -eakl | sort -n +6 | head

 

To display processes in order of time: ps vx | head -1 ; ps vx | grep -v PID | sort -rn +3 | head -10

 

To display processes in order of real memory use: ps vx | head -1 ; ps vx | grep -v PID | sort -rn +6 | head -10

 

To display processes in order of I/O: ps vx | head -1 ; ps vx | grep -v PID | sort -rn +4 | head -10

 

To determining the PID of wait processes: ps vg | head -1 ; ps vg | grep -w wait

0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
sysdumpdev Command
Viewed 1824 times since Mon, Jul 16, 2018
How to know witch process is running in a particular port on AIX using KDB
Viewed 12624 times since Thu, Nov 29, 2018
Top 4 Reasons for Node Reboot or Node Eviction in Real Application Cluster (RAC) Environment
Viewed 90010 times since Thu, Jun 21, 2018
Create a mksysb + SPOT using NIM (CLI)
Viewed 5533 times since Tue, Jul 17, 2018
IVM and VLAN Tagging
Viewed 10300 times since Mon, May 28, 2018
Manually Editing /etc/filesystems Can Cause Issues
Viewed 5382 times since Tue, May 22, 2018
AIX Commands Related to Boot and Init Process
Viewed 4540 times since Tue, Apr 16, 2019
Migrating AIX User Environments
Viewed 2162 times since Wed, May 30, 2018
Reconfigure RSCT ID to fix DLPAR issues on cloned AIX systems
Viewed 13743 times since Thu, Feb 21, 2019
0516-787 extendlv: Maximum allocation for logical volume error
Viewed 8790 times since Tue, Mar 12, 2019