AIX oslevel version OS

####
oslevel -sq
Known Service Packs
-------------------
7200-02-02-1810 <---- BL TL ML YY WW ---> 7200 02 02 18 10
7200-02-02-1806
7200-02-01-1732
7200-02-01-1731
7200-02-00-0000
7200-01-04-1806
7200-01-03-1720
7200-01-02-1717
7200-01-01-1642
7200-00-06-1806
7200-00-05-1720
7200-00-04-1717
7200-00-03-1642
7200-00-02-1614
7200-00-01-1543


oslevel -s
5300-09-02-0849

This will give you

"5300" - Base Level
"09" - Technology Level
"02" - Maintenance Level
"0849" - Service Pack


function aixversion {
OSLEVEL=$(oslevel -s)
AIXVERSION=$(echo "scale=1; $(echo $OSLEVEL | cut -d'-' -f1)/1000" | bc)
AIXTL=$(echo $OSLEVEL | cut -d'-' -f2 | bc)
AIXSP=$(echo $OSLEVEL | cut -d'-' -f3 | bc)
echo "AIX ${AIXVERSION} - Technology Level ${AIXTL} - Service Pack ${AIXSP}"
}
aixversion

Example output:

AIX 7.1 - Technology Level 3 - Service Pack 1

oslevel -s | awk -F- '{printf "AIX %.1f - Technology Level %d - Service Pack %d\n",$1/1000,$2,$3}'
AIX 7.2 - Technology Level 2 - Service Pack 2

 

https://www.ibm.com/it-infrastructure/power/os/aix

prtconf | grep Firmware
lsmcode -c

https://www.unix.com/aix/134637-how-upgrade-aix-firmware-tl-maintenance-level-aix.html

https://computing.llnl.gov/tutorials/ibm_sp/

https://www.billsden.org/dsi/admin/ibm/install/nim/nim.htm


####

5 (1)
Article Rating (1 Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
This document discusses a new feature implemented for JFS2 filesystems to prevent simultaneous mounting.
Viewed 2792 times since Sat, Jun 1, 2019
Troubleshooting Starts With Understanding Your Physical Disks’ Attributes
Viewed 3737 times since Sat, May 19, 2018
AIX, Storage, System Admin Allocating shared storage to VIOS clients
Viewed 2272 times since Fri, Apr 19, 2019
How to Easily Generate AIX Systems Management Reports
Viewed 2944 times since Wed, May 30, 2018
AIX Creating a Volume Group
Viewed 2472 times since Tue, Jul 17, 2018
AIX Cloning a rootvg using alternate disk installation
Viewed 11516 times since Sun, Jun 30, 2019
Convert to Scalable Volume Groups
Viewed 3782 times since Wed, May 30, 2018
Create a mksysb + SPOT using NIM (CLI)
Viewed 5534 times since Tue, Jul 17, 2018
AIX, Installation, NIM↑ Creating an LPP source and SPOT in NIM
Viewed 14753 times since Fri, Apr 19, 2019
Working with Virtual media library on VIO servers
Viewed 15135 times since Thu, Feb 21, 2019