AIX: Script to get Total Disk Size

Single Server

Total Disk Size (hdisk)

1
for i in `lspv |awk '{print $1}'`; do bootinfo -s $i; done |awk '{s+=$1} END {print s}' |while read x; do echo $x/1024|bc; done

Total Disk Size (hdiskpower)

1
for i in `lspv |grep hdiskpower |awk '{print $1}'`; do bootinfo -s $i; done |awk '{s+=$1} END {print s}' |while read x; do echo $x/1024|bc; done
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
How to Use the Linux lsof Command
Viewed 11948 times since Sun, Jun 30, 2019
Manually Editing /etc/filesystems Can Cause Issues
Viewed 5841 times since Tue, May 22, 2018
A Change to the SMT Mode Default in POWER9
Viewed 5626 times since Fri, Jan 18, 2019
IBM AIX multipath I/O (MPIO) resiliency and problem determination
Viewed 13983 times since Wed, May 30, 2018
Awesome Command to show top 15 processes using memory on AIX
Viewed 24137 times since Thu, Nov 29, 2018
AIX - How to unlock and reset user’s account
Viewed 17096 times since Fri, Jun 8, 2018
Oslevel shows wrong AIX’s level. Why
Viewed 4967 times since Thu, Feb 21, 2019
Useful AIX general commands
Viewed 12223 times since Wed, Apr 17, 2019
A tcpdump Tutorial and Primer with Examples
Viewed 5466 times since Sun, Jun 17, 2018
View mksysb content & restore individual files
Viewed 2069 times since Tue, Jul 17, 2018