AIX Creating EtherChannel Devices from Command Line

I needed to create some EtherChannel devices on several AIX LPARs, and did not want to go through the smit panels every time.

I was testing network performance and wanted to add these to a script, so I could test standalone adapter configurations vs EtherChannel configurations, and leave my scripts running over night.

Here are the steps to create an EtherChannel device on AIX.

 

Create the eth device.  My primary Ethernet adapter is ent1 and the backup adapter is ent3.  This EtherChannel device will fail-over to the backup adapter and fail-back to the primary automatically.  The netaddr supplied is a reliable network device to ping to confirm which adapters are up or down, so I used the default gateway.

mkdev -c adapter -s pseudo -t ibm_ech -a adapter_names='ent1' -a backup_adapter='ent3' -a netaddr='192.168.2.1' -a num_retries='2' -a retry_time='1'

 

Create the et and en devices.

/usr/lib/methods/defif

 

Now add the IP address to the EtherChannel device.

chdev -l en4 -a netaddr=192.168.2.100 -a netmask=255.255.255.0 -a state=up

 

To clean up and delete the EtherChannel, just rmdev the ent, en and et devices, then configure one of the standalone adapters with the servers IP address as needed.

 

0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Part 1, Network overview - Monitoring the hardware
Viewed 5050 times since Mon, Jun 4, 2018
AIX Encrypted File System
Viewed 5444 times since Tue, Jul 17, 2018
Configure log file for cron daemon on AIX
Viewed 9569 times since Thu, Feb 21, 2019
AIX: How to set automatic logoff (only for terminals)
Viewed 2631 times since Mon, Jun 11, 2018
AIX Creating a Volume Group
Viewed 2189 times since Tue, Jul 17, 2018
How to know witch process is running in a particular port on AIX using KDB
Viewed 11894 times since Thu, Nov 29, 2018
How to determine why your AIX oslevel is downlevel (and a script to help!)
Viewed 3406 times since Fri, Jul 13, 2018
How To Mirror VG and Root VG
Viewed 2658 times since Mon, May 21, 2018
AIX Net How to check VLAN ID number on AIX?
Viewed 14445 times since Thu, Nov 29, 2018
0516-404 allocpThis system cannot fulfill the allocation
Viewed 9708 times since Thu, Sep 20, 2018