LVM: Extend an existing Volume Group by adding a new disk

LVM: Extend an existing Volume Group by adding a new disk

# Tested on AIX 6.1

# First, verify the disk(s) to use on the VG with "lspv" or any other similar tool.
# Ensure that disk is not being used/

lspv
   hdisk0          00f7136bab316a7a                    rootvg          active
   hdisk1          00f7136b82d34d5a                    datavg          active
   hdisk2          none                                None
   hdisk3          none                                None
   hdisk4          none                                None
   hdisk5          none                                None
   hdisk6          none                                None
   hdisk7          none                                None
   hdisk8          none                                None    <----
   hdisk9          none                                None


DISK=hdisk8
VG=datavg

# Check before

lsvg $VG
   VOLUME GROUP:       datavg                   VG IDENTIFIER:  00f7136b00004c000000013782d34d78
   VG STATE:           active                   PP SIZE:        128 megabyte(s)
   VG PERMISSION:      read/write               TOTAL PPs:      103 (13184 megabytes)   <----
   MAX LVs:            512                      FREE PPs:       0 (0 megabytes)
   LVs:                2                        USED PPs:       103 (13184 megabytes)
   OPEN LVs:           2                        QUORUM:         2 (Enabled)
   TOTAL PVs:          1                        VG DESCRIPTORS: 2
   STALE PVs:          0                        STALE PPs:      0
   ACTIVE PVs:         1                        AUTO ON:        yes
   MAX PPs per VG:     130048
   MAX PPs per PV:     1016                     MAX PVs:        128
   LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
   HOT SPARE:          no                       BB POLICY:      relocatable
   PV RESTRICTION:     none                     INFINITE RETRY: no



# Add disk to VG

extendvg $VG $DISK
   0516-1254 extendvg: Changing the PVID in the ODM.


# Check after

lspv
   hdisk0          00f7136bab316a7a                    rootvg          active
   hdisk1          00f7136b82d34d5a                    datavg          active
   hdisk2          none                                None
   hdisk3          none                                None
   hdisk4          none                                None
   hdisk5          none                                None
   hdisk6          none                                None
   hdisk7          none                                None
   hdisk8          00c6b1c5fa811973                    datavg          active   <----
   hdisk9          none                                None


lsvg $VG
   VOLUME GROUP:       datavg                   VG IDENTIFIER:  00f7136b00004c000000013782d34d78
   VG STATE:           active                   PP SIZE:        128 megabyte(s)
   VG PERMISSION:      read/write               TOTAL PPs:      206 (26368 megabytes)   <----
   MAX LVs:            512                      FREE PPs:       103 (13184 megabytes)
   LVs:                2                        USED PPs:       103 (13184 megabytes)
   OPEN LVs:           2                        QUORUM:         2 (Enabled)
   TOTAL PVs:          2                        VG DESCRIPTORS: 3
   STALE PVs:          0                        STALE PPs:      0
   ACTIVE PVs:         2                        AUTO ON:        yes
   MAX PPs per VG:     130048
   MAX PPs per PV:     1016                     MAX PVs:        128
   LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
   HOT SPARE:          no                       BB POLICY:      relocatable
   PV RESTRICTION:     none                     INFINITE RETRY: no
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
Online Backups and Recovery in a Snap AIX
Viewed 5090 times since Wed, May 30, 2018
Mirroring the rootvg Volume Group for AIX
Viewed 3964 times since Mon, May 21, 2018
AIX -- extending Logical Volumes online
Viewed 2731 times since Tue, Mar 12, 2019
Managing System Dump Devices sysdumpdev
Viewed 3432 times since Mon, Jul 9, 2018
AIX - How to monitor memory usage
Viewed 5327 times since Fri, Jun 8, 2018
AIX: How to determine which application created the OS core file
Viewed 2453 times since Mon, Jun 11, 2018
AIX HA / HACMP, System Admin↑ Mountguard
Viewed 6820 times since Mon, Jun 3, 2019
AIX Health Check basic
Viewed 4477 times since Fri, Jun 8, 2018
Topics: AIX, System Admin↑ Export and import PuTTY sessions
Viewed 3009 times since Fri, Apr 19, 2019
AIX, Networking↑ Adding and deleting a static network route using the command line
Viewed 2668 times since Fri, Apr 19, 2019