IP configuration in AIX

IP configuration in AIX

Here are some TCP/IP related commands, might be usefull.
Generally by using ifconfig and route commands your settings will not be preserved after the reboot, because the settings will not be stored in the ODM.
So to make the settings persistent across reboots use mktcpip or chdev for IP configuration and for the routing table smit route, /etc/rc.net or chdev

List routes stored in ODM

# odmget -q "attribute=route" CuAt

View curent routing table

# netstat -rn

Delete default route (persistent)

# chdev -l inet0 -a delroute=net,-hopcount,0,,0,192.168.2.2

Define default route (persistent)

# chdev -l inet0 -a route=net,-hopcount,0,,0,192.168.2.1

Lookup route information

# route get 

To permanently assign a IP to the en1 interface:

# chdev -l en1 -a netaddr=192.168.2.98 -a netmask=255.255.255.0

The following command sets the IP configuration on the specified adpter, adds an entry into /etc/hosts, and adds a static route to the routing table.

                  | Hostname           
# mktcpip -i en2 -h power1 -g 192.168.2.2 -a 192.168.4.6 -m 255.255.255.0
           |                |              |              |
           Interface        Gateway        Address        Netmask

View inet0 configuration

# lsattr -El inet0

To create a persistent IP alias:

         Interface name
         | 
# chdev -l en0 -a alias4=192.168.4.77,255.255.255.0
en0 changed     |
                Attribute

To permanently remove an IP alias

         Interface name     IP and netmask as shwon in `lsattr -El en0`
         |                  | 
# chdev -l en0 -a delalias4=192.168.2.77,255.255.255.0
en0 changed     |
                Attribute

Media link speed for the en0 interface

# entstat -d en0 | grep "Media Speed"

Show all listening ports

netstat -anf inet | grep LISTEN

Show domain name server settings

# namerslv -s
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
AIX www web Links
Viewed 2817 times since Fri, Apr 19, 2019
AIX Creating EtherChannel Devices from Command Line
Viewed 2473 times since Mon, Jun 3, 2019
Create memory resident filesystems (RAM disk) on AIX
Viewed 2281 times since Thu, Feb 21, 2019
How To Mirror Your Root Disk On AIX (a.k.a. rootvg)
Viewed 4497 times since Mon, May 21, 2018
Find out which port the daemon is using on AIX OS. (similar like command netstat -anp for Linux)
Viewed 10367 times since Thu, Feb 21, 2019
AIX, Networking↑ Adding and deleting a static network route using the command line
Viewed 2195 times since Fri, Apr 19, 2019
Topics: PowerHA / HACMP, Storage Adding a new volume group to an active PowerHA resource group
Viewed 2196 times since Mon, Jun 3, 2019
Do you Know These 5 Use of V$session View ?
Viewed 82035 times since Thu, Jun 21, 2018
Understanding dump devices sysdumpdev
Viewed 4005 times since Mon, Jul 9, 2018
AIX -- extending Logical Volumes online
Viewed 2386 times since Tue, Mar 12, 2019