Script to show Total, Free and Used Memory on AIX

Just Copy and Paste:

(memory=`prtconf -m | awk 'BEGIN {FS=" "} {print $3/1024}'`
usedmem=`svmon -G | grep memory | awk 'BEGIN {FS=" "} {print $3/256/1024}'`
freemem=`echo $memory-$usedmem | bc -l`
clear
echo
echo "Memory Results:"
echo "----------------------"
echo
echo "Avai Mem: $memory GB"
echo "Free Mem: $freemem GB"
echo "Used Mem: $usedmem GB"
echo
echo)

Result:

Memory Results:
----------------------

Avai Mem: 2 GB
Free Mem: 0.69649 GB
Used Mem: 1.30351 GB
0 (0)
Article Rating (No Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
How To Mirror VG and Root VG
Viewed 3545 times since Mon, May 21, 2018
Reconfigure RSCT ID to fix DLPAR issues on cloned AIX systems
Viewed 14388 times since Thu, Feb 21, 2019
How to determine why your AIX oslevel is downlevel (and a script to help!)
Viewed 4568 times since Fri, Jul 13, 2018
Using the AIX splitvg command
Viewed 4494 times since Mon, Jun 3, 2019
HOWTO: Copy a filesystem on AIX
Viewed 2665 times since Mon, May 28, 2018
How to set Kernel Parameters in AIX ?
Viewed 15340 times since Tue, Jul 2, 2019
AIX check the HBA status
Viewed 17109 times since Tue, May 22, 2018
AIX Health Check basic
Viewed 4925 times since Fri, Jun 8, 2018
AIX- Procedure to replace rootvg harddisk
Viewed 4824 times since Tue, Apr 16, 2019
vfcpmap on VIO Server
Viewed 9780 times since Tue, Jun 4, 2019