Configure log file for cron daemon on AIX

Cron daemon log in by default on /var/adm/cron/log, but I wanted to put it with all other logs of the system.
All system logs (syslog, mksysb, ftp, http, and so on, are on /var/syslog filesystem, I decided to put cron logs in the same place. Here’s what I did.

Add this lines to the end of file /etc/cronlog.conf

logfile=/var/syslog/cron.log
size=2m
rotate=4
archive=/var/syslog
compress

As cron is started from inittab it will respawn when you kill the PID.

[root@aix:/] cat /etc/inittab|grep cron
cron:23456789:respawn:/usr/sbin/cron

So, just kill cron’s PID (10748102 in this case)

[root@aix:/var/adm/cron] ps -ef|grep cron
    root 10748102        1   0 18:35:42      -  0:00 /usr/sbin/cron

Note also that cron log wil be rotate and compress. See:

[root@bibmnim:/var/adm/cron] ls -ltr /var/syslog/
total 18752
drwxr-xr-x    2 root     system          256 Mar 01 2011  lost+found
-rw-rw-r--    1 root     cron         164711 Apr 21 23:58 cron.log.0.Z
-rw-rw-r--    1 root     cron         165926 Apr 27 12:29 cron.log.1.Z
-rw-rw-r--    1 root     cron         165527 May 03 01:01 cron.log.2.Z
-rw-rw-r--    1 root     cron         164224 May 08 13:45 cron.log.3.Z
-rw-rw-r--    1 root     cron           1493 May 13 18:41 cron.log

That’s it!

Just thanks if the post was helpful

5 (1)
Article Rating (1 Votes)
Rate this article
Attachments
There are no attachments for this article.
Comments
There are no comments for this article. Be the first to post a comment.
Full Name
Email Address
Security Code Security Code
Related Articles RSS Feed
AIX boot proccess
Viewed 2432 times since Tue, Apr 16, 2019
AIX - How to monitor memory usage
Viewed 4017 times since Fri, Jun 8, 2018
SNAP
Viewed 1502 times since Mon, Sep 17, 2018
Part 2, NFS monitoring and tuning
Viewed 5961 times since Mon, Jun 4, 2018
O’Reilly’s CD bookshelf
Viewed 11025 times since Wed, Jun 27, 2018
AIX Migrating from SDDPCM to AIXPCM (the easy way)
Viewed 19152 times since Mon, Dec 31, 2018
Installing a Interim Fix (APAR IV16587)
Viewed 2541 times since Tue, Jul 17, 2018
Part 1, The basics of network troubleshooting
Viewed 2912 times since Tue, May 22, 2018
n a perfect world....rootvg would always reside on hdisk0
Viewed 1937 times since Thu, Jun 6, 2019
AIX 0516-404 allocp: This system cannot fulfill the allocation
Viewed 2923 times since Thu, Sep 20, 2018